无标题文档
wdCP系统 (介绍,功能特性,运行环境,安装说明,演示,常见问题,使用教程) wdCDN系统 (介绍,功能特性,运行环境,安装说明,演示,常见问题,使用手册)
wdOS系统 (介绍,功能特性,运行环境,安装说明,演示,常见问题,使用教程) wdDNS系统 (介绍,功能特性,运行环境,安装说明,演示,常见问题,使用手册)
注册 发贴 提问 回复-必看必看 wddns免费智能 DNS 开通 本地或虚拟机使 用wdcp 一键包在mysql编 译时"卡住"
【300G高防】双线 无视攻击 wdcp官方技术支持/服务 阿里云8折优惠券 无敌云 腾讯云优惠中,现注册更有260代金额券赠送
返回列表 发帖
提问三步曲: 提问先看教程/FAQ索引(wdcp,wdcp_v3,一键包)及搜索,会让你更快解决问题
1 提供详细,如系统版本,wdcp版本,软件版本等及错误的详细信息,贴上论坛或截图发论坛
2 做过哪些操作或改动设置等

温馨提示:信息不详,很可能会没人理你!论坛有教程说明的,也可能没人理!因为,你懂的

[教程] v3升级到v3.2后,多PHP版本共存的安装方法

自v3.2开始,wdcp支持多PHP版本共存共用和切换,可根据需求灵活选择和使用
从v3.0/3.1升级的用户,还需要再安装下多版本的PHP环境,才可完全正常使用和切换

安装方法如下:
wget http://down.wdlinux.cn/in/phps.sh
sh phps.sh
(共支持8个版本的PHP,如5.2.17/5.3.29/5.4.45/5.5.38/5.6.30/7.0/7.2/7.3)

可直接执行sh phps.php
会提示相应的版本选择安装或安装全部

也可以针对或指定某个版本,如
sh phps.sh 7.1.4
即可安装7.1.4

多版本PHP的手动启动|停止|重起
如:5.5
/www/wdlinux/phps/55/bin/php-fpm start
/www/wdlinux/phps/55/bin/php-fpm stop
/www/wdlinux/phps/55/bin/php-fpm restart
如是其它版本,把55替换为相应版本即可

如无特别求,可不必全部安装或启动,因为启动多一个,就会占资源多一份

已知问题
CentOS 7.X系列系统,不再支持php-5.2/5.3的老版本PHP,可考虑使用CentOS 6.X
看清提问三步曲及多看教程/FAQ索引(wdcp,v3,一键包,wdOS),益处多多.wdcp工具集 阿里云主机8折优惠码

7.3.2 install complete

     
  1. configurations
复制代码
, phps install is complete
      visit http://ip:8080
      more infomation please visit http://www.wdlinux.cn/bbs/
大佬,恭喜的英文写错了啊
呵呵

TOP

搞了半天没装上,原来云锁在做怪,把云锁操作系统加固关掉就能装了

TOP

学习了啊,很赞,很需要
爱好是一种

TOP

lnmp模式不能自动启动php,如何设置
俺本仁慈

TOP

本帖最后由 lytliang 于 2019-7-9 11:08 编辑

安装时选择4 安装的是php5.6  不想安装其他的php版本, 如何切换成lnmp模式,提示让我设置php默认版本 如何设置默认版本,就装了一个php5.6版本啊

被逼无奈,我安装了php7.0  运行 设置默认提示我未运行

哪里有个详细的教程啊?
俺本仁慈

TOP

请问有 ubuntu 的版本的 sh 吗? 非常感谢 !
linux

TOP

5.4.45失效,5.6.30也无效
没个性签名

TOP

楼主重装了后,发现
s h phps.sh 7.x.x
及以上全部失效,从sh文件里,我发现最新的是php7.2.13,但是也无效

TOP

wget http://down.wdlinux.cn/in/phps.sh
这个php.sh随时可能更新,即,里面所含的版本号不一定跟楼主当时举例的内容一直,建议先查看一下包内容,里面可以看到支持哪些版本号,再根据自己的需求安装;
例如,我wget好phps.sh这个文件,用sh phps.sh 7.1.4指定不能安装时候,我就先回到phps.sh这个文件的当前目录,一般使用wget下载的文件,都是在当前目录,用ls命令查看一下,当前目录有没有这个文件,
若无,检查自己wget命令的下载目录在哪里,
若有,则用cat命令查看一下,
我当时看了里面的包已经没有7.1.4版本了,要么7.1.25,要么7.2.X,所以我就装了7.1.25,一路顺利安装完成,仅此提供一些思路;
顺便吐槽一下楼主教程不怎么严谨。哈哈,毕竟分享,尽量简单让人通俗理解嘛,共勉;

TOP

没有fileinfo扩展应该怎么办

TOP

php-5.2.17/README.WIN32-BUILD-SYSTEM
2
loading cache ./config.cache
checking for Cygwin environment... no
checking for mingw32 environment... no
checking for egrep... grep -E
checking for a sed that does not truncate output... /bin/sed
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking for gcc... gcc
checking whether the C compiler (gcc  ) works... no
configure: error: installation or configuration problem: C compiler cannot create executables.
ln: 创建符号链接 "/usr/lib/libmysqlclient.a": 文件已存在
ln: 创建符号链接 "/usr/lib/libmysqlclient_r.a": 文件已存在
ln: 创建符号链接 "/usr/lib/libmysqlclient_r.so": 文件已存在
ln: 创建符号链接 "/usr/lib/libmysqlclient_r.so.18": 文件已存在
ln: 创建符号链接 "/usr/lib/libmysqlclient_r.so.18.0.0": 文件已存在
ln: 创建符号链接 "/usr/lib/libmysqlclient.so": 文件已存在
ln: 创建符号链接 "/usr/lib/libmysqlclient.so.18": 文件已存在
ln: 创建符号链接 "/usr/lib/libmysqlclient.so.18.0.0": 文件已存在
ln: 创建符号链接 "/usr/lib/libmysqld.a": 文件已存在
ln: 创建符号链接 "/usr/lib/libmysqlservices.a": 文件已存在
phps.sh: line 82: /usr/bin/make: 权限不够


x86_64
CentOS release 6.5 (Final)
----Install Error: 5.2.17 -----------
新手一枚

TOP

我安装php多版本提示
phps.sh: line 82: /usr/bin/make: 权限不够
老大这是怎么回事
新手一枚

TOP

[img][/img]
新手一枚

TOP

[img][/img]
新手一枚

TOP

返回列表