Board logo

标题: [求助] lanmp v2.5 选php 5.3.26后安装mysqli扩展出错问题 [打印本页]

作者: cvober    时间: 2013-7-20 21:34     标题: lanmp v2.5 选php 5.3.26后安装mysqli扩展出错问题

本帖最后由 cvober 于 2013-7-20 21:38 编辑

lanmp v2.5 选php 5.3.26后按http://www.wdlinux.cn/bbs/thread-1356-1-1.html方式安装mysqli扩展出错,按http://www.wdlinux.cn/bbs/thread-4184-1-1.html方式解决不了,打开mysqli_ins.sh文件后发现里面是if [ -d /root/lanmp/php-5.2.17/ext/mysqli ];then
        cd /root/lanmp/php-5.2.17/ext/mysqli

老大能不能提供个新安装mysqli的脚本,谢谢
补充一下,这个系统选择安装php-5.2.17后是可以正常安装mysqli的,我的一个插件需要PHP5.3以上版本,但是在php-5.2.17升级5.3后网站空白,不得已重新配置系统。请高手帮忙看下。

错误提示见附图
QQ图片20130720212811.jpg
2013-7-20 21:30


图片附件: QQ图片20130720212811.jpg (2013-7-20 21:30, 122.58 KB) / 下载次数 3013
http://www.wdlinux.cn/bbs/attachment.php?aid=3250&k=08909dbcc5d4937bce49c93186e98cd5&t=1716418941&sid=X1hAR0


作者: itxx    时间: 2013-7-21 23:49

回复 1# cvober

5.3的mysqli等相关脚本明天更新,或者如果你要重新安装环境的话可以使用github上面最新的脚本进行安装,最新脚本默认会安装mysqli等拓展。
作者: itxx    时间: 2013-7-23 19:55

php5.3的mysqli单独安装脚本地址https://github.com/wdlinux/lanmp ... mysqli5.3.26_ins.sh
作者: cvober    时间: 2013-7-24 13:28

谢谢版主~~~~~~~~~~~~~~~~~
作者: cvober    时间: 2013-7-30 14:30

github上面最新的脚本在centos 64Bit安装mysql失败,版主发的更新脚本mysqli5.3.26_ins.sh在64位系统也不能安装,是否可以查一下
作者: cvober    时间: 2013-7-30 15:04

更新脚本mysqli5.3.26_ins.sh在64位系统出错提示

QQ图片20130730150115.jpg
2013-7-30 15:04


图片附件: QQ图片20130730150115.jpg (2013-7-30 15:04, 98.6 KB) / 下载次数 2997
http://www.wdlinux.cn/bbs/attachment.php?aid=3335&k=3d3076e581e1f1212f71462b49422da4&t=1716418941&sid=X1hAR0


作者: admin    时间: 2013-7-31 10:51

是下载的文件有问题吧
作者: cvober    时间: 2013-7-31 11:03

是下载的文件有问题吧
admin 发表于 2013-7-31 10:51



   感谢老大提醒,我直接用 wget 了版主提供的链接,刚刚点开链接发现里面还有代码,复制代码过去,现在正常运行了,哈哈




欢迎光临 WDlinux官方论坛 (http://www.wdlinux.cn/bbs/) Powered by Discuz! 7.2