Board logo

标题: [发布] wdcp_v3.3版本发布 [打印本页]

作者: admin    时间: 2018-12-11 21:26     标题: wdcp_v3.3版本发布

v3.3版本主要更新如下
增加tomcat应用环境的支持
增加nodejs应用程序的支持
增加反向代理/CDN的功能
增加负载均衡的功能
上述功能均要在N或N+A引擎下有效
增加SSL证书创建后自动续期
增加站点到期时间的设置
增加专业版授权功能
增加mysql数据库的root密码查看
增加mysql端口的自定义支持
优化ftp用户的帐号管理
优化ssl证书创建及流程
修复IP网关显示不准的问题
调整优化mysql密码加密存储(解决上个版本明文存储的安全问题)
系统内核及部分功能及流程优化


安装方法(请使用纯净系统,即不带任何其它WEB环境的系统)
1 只安装wdcp面板看看
wget http://down.wdlinux.cn/in/install_v3.sh
sh install_v3.sh

2 和lanmp环境一起安装
yum install -y wget
wget http://dl.wdlinux.cn/files/lanmp_v3.3.tar.gz
tar zxvf lanmp_v3.3.tar.gz
sh lanmp.sh

升级方法
直接后台升级

如升级错误或无法打开,可使用手动升级
SSH登录服务器,执行
sh /www/wdlinux/wdcp/shell/updates.sh

更多的说明,可参考
https://www.wdlinux.cn/bbs/thread-57643-1-1.html
作者: bit    时间: 2018-12-12 09:09

本帖最后由 bit 于 2018-12-13 22:14 编辑

祝wdcp越来越好
作者: pkkgu    时间: 2018-12-12 09:56

收费版换服务器 要重新收费吗?
作者: bit    时间: 2018-12-12 11:07

回复 3# pkkgu


   应该可以转移授权
作者: al277    时间: 2018-12-12 11:34

66666666666666666
作者: gaofeiyue    时间: 2018-12-12 13:00

升级完以后,查看数据库密码提示:当前的mysql密码错误,请重新设置或修改;
新建FTP用户或是修改的时候也提示:FTP数据库的用户密码错误
作者: gaofeiyue    时间: 2018-12-12 13:01

升级完以后,查看数据库密码提示:当前的mysql密码错误,请重新设置或修改;
新建FTP用户或是修改的时候也提示:FTP数据库的用户密码错误
这个改怎么解决呢?
作者: gaofeiyue    时间: 2018-12-12 13:21

升级完以后,查看数据库密码提示:当前的mysql密码错误,请重新设置或修改;
新建FTP用户或是修改的时候也提示:FTP数据库的用户密码错误
这个该怎么解决呢?
作者: admin    时间: 2018-12-12 14:57

回复 8# gaofeiyue

手动再升级下
作者: zxzcad    时间: 2018-12-12 15:20

我去在线升级试试。
作者: wdcpma    时间: 2018-12-12 16:57

WDCP 不错 一路支持 完美解决LINUX 集成环境 大大降低使用效率
作者: dbxinxi    时间: 2018-12-13 08:23

本帖最后由 dbxinxi 于 2018-12-13 08:26 编辑

不管在线升级还是手动升级,升级完后,都无法备份数据库
作者: dbxinxi    时间: 2018-12-13 08:28

回复 9# admin
手动升级完后,还是无法备份数据库,提示“mysql密码错误,备份失败!”,改完数据库密码后再备份,还是无法备份!
作者: bloodman    时间: 2018-12-13 11:56

本帖最后由 bloodman 于 2018-12-13 12:01 编辑

回复 7# gaofeiyue


   我也是这个问题。但是我知道是因为数据库少了。不知道全新安装会不会有问题,一会开个虚拟机试试
作者: bloodman    时间: 2018-12-13 11:59

回复 1# admin


   老大,更新后ftp的数据库好像没有。这个配置文件是在哪查找?我好根据配置文件创建下这个数据库跟连接信息
作者: zhaohengde    时间: 2018-12-13 12:06

后台升级后系统负载不显示
作者: bloodman    时间: 2018-12-13 14:05

回复 10# zxzcad


   在线升级会报错的
作者: hionline    时间: 2018-12-13 15:28

我是直接安装新版的,FTP一直连不上,一开始是530错误,折腾一次后是无法获取目录列表。现在考虑要不要装回3.2,老大我该怎么办
作者: admin    时间: 2018-12-13 20:48

后台升级后系统负载不显示
zhaohengde 发表于 2018-12-13 12:06


用前面说的,手动再更新一下
作者: bit    时间: 2018-12-13 21:26

回复 9# admin


   全新安装3.3的时候选择MySQL 5.7安装出错:
CMake Error at cmake/boost.cmake:81 (MESSAGE):
  You can download it with -DDOWNLOAD_BOOST=1 -DWITH_BOOST=<directory>

  This CMake script will look for boost in <directory>.  If it is not there,
  it will download and unpack it (in that directory) for you.

  If you are inside a firewall, you may need to use an http proxy:

  export http_proxy=http://example.com:80

Call Stack (most recent call first):
  cmake/boost.cmake:238 (COULD_NOT_FIND_BOOST)
  CMakeLists.txt:507 (INCLUDE)


-- Configuring incomplete, errors occurred!
See also "/root/src/mysql-5.7.24/CMakeFiles/CMakeOutput.log".
See also "/root/src/mysql-5.7.24/CMakeFiles/CMakeError.log".
作者: doufenger    时间: 2018-12-16 16:17

回复 9# admin


   我的是手动升级的 现在创建不了网站了, 也是提示系统检测当前的mysqlroot密码错误
作者: zwehon    时间: 2018-12-16 21:58

回复 1# admin
默认使用wdlinux.cn是无效,然后强制修改mysql的root密码后使用新的密码也出现密码错误
sh /www/wdlinux/wdcp/shell/mysqlrootchp.sh
作者: 嘿嘿d礼服    时间: 2018-12-17 16:01

老大,恕我愚钝………v3.3支持apsx里吗……确定支持aspx里吗……谢谢老大……我都快等疯了
作者: giantzhi    时间: 2018-12-17 18:40

升级了这个版本,有好多问题,导致我的阿里云数据盘丢失。已经升级的,有办法回恢复到前一下版本吗?
作者: giantzhi    时间: 2018-12-17 18:42

新的站点,数据库创建不了,旧的站点ftp登录不了
作者: giantzhi    时间: 2018-12-17 19:15

升级后真的好多问题,手动升级后也解决不了,有没有什么办法退回到以前版本?
作者: lilv7214    时间: 2018-12-18 10:26

额,更新后,wdcp打不开了,网站没问题
作者: lilv7214    时间: 2018-12-18 10:36

额,更新后,wdcp打不开了,网站没问题
lilv7214 发表于 2018-12-18 10:26


进服务器重启了一下wdcp,又好了,暂时没发现其他问题
作者: zbw7415604    时间: 2018-12-18 10:55

手动升级完后新建数据库还是提示root密码设置,输入原来的root密码,也提示错误!!!!
作者: cmsphp    时间: 2018-12-18 17:08

升级以后  现在创建不了网站了, 也是提示系统检测当前的mysqlroot密码错误 求解
作者: hanxing    时间: 2018-12-23 20:55

各位大佬,现在升级v3.3.1稳定没呀??新手小白不敢乱动
作者: 情迷戈壁滩    时间: 2018-12-27 12:41

原来是3.2.21  看到后台有最新的3.3*的版本 就点了更新 点了后  wdcp 后台进不去了页面打不开 什么鬼啊?
作者: kenkenms    时间: 2018-12-28 17:37

CentOS 7 配置如何?之前的版本3.2版本搭配CentOS 7是有點問題的,包括站点建设,MYSQL数据库用户权限等等。
作者: xtssc    时间: 2018-12-31 19:42

Nginx配置文件有错
nginx: [emerg] getpwnam("www") failed in /www/wdlinux/nginx-1.8.1/conf/nginx.conf:4
nginx: configuration file /www/wdlinux/nginx-1.8.1/conf/nginx.conf test failed

Apache配置文件有错
AH00543: httpd: bad user name www
作者: gaorunqiang    时间: 2019-1-2 11:52

站点删除报错。wdCP err link
作者: jesonzxj    时间: 2019-1-5 23:22

站点删除报错。wdCP err link
作者: zyfpay    时间: 2019-1-19 14:46

回复 1# admin


    创建SSL证书提示数据错误,怎么办
作者: xuxus    时间: 2019-1-25 19:48

祝wdcp越来越好!!!!!!!!!!!
作者: shahaohaosha    时间: 2019-1-27 11:09

怎么支持 php 7.2
作者: 凝尘    时间: 6 天前 09:27

更新版本后样式有问题进入站点文件管理后 下面的快捷操作不能显示出来样式有问题




欢迎光临 WDlinux官方论坛 (http://www.wdlinux.cn/bbs/) Powered by Discuz! 7.2