Board logo

标题: [发布] lanmp v2.3一键安装包发布(包括lamp,lnmp,lnamp安装) [打印本页]

作者: admin    时间: 2012-5-28 10:34     标题: lanmp v2.3一键安装包发布(包括lamp,lnmp,lnamp安装)

lanmp一键安装包是wdlinux官网2010年开始推出的lamp,lnmp,lnamp(apache,nginx,php,mysql,zend,eAccelerator,pureftpd)应用环境的快速简易安装包,执行一个脚本,整个环境就安装完成就可使用,快速,方便易用,安全稳定
1 支持lamp(linux+apache+php+mysql),lnmp(linux+nginx+php+mysql)环境快速安装部署上线
2 支持lnamp,即支持nginx+apache组合环境的应用,也即是nginx前端处理静态,图片等,apche处理后台php脚本程序。nginx在处理静态文件上有着非常好的性能和稳定性,且省节点资源,但在处理php的应用上相对没那么稳定,而apache在处理php的应用上是非常稳定的,也因此,目前比较流行的一个n+a的组合应用应运而生
3 同时集成最新版本的wdcp服务器/虚拟主机管理系统,wdcp (WDlinux Control Panel)是一套Linux服务器/虚拟主机管理系统,可通过web界面对服务器进行日常的管理和维护,省去通过终端输命令的烦琐操作和难度,更是降低了使用Linux做web服务器的门槛,让更多人的可以轻松使用Linux做服务器。以及可以管理网站,FTP,数据库等,包括在线创建,删除,修改等操作,详细功能介绍可查看http://www.wdlinux.cn/wdcp
4 支持WdLinux定制版,CentOS,RedHat,ubunntu,更多的版本支持将在后续增加,也欢迎测试

此次更新
1 增加ubuntu系统的支持,测试版本为12.04
2 增加安装环境切换,可切换到lamp,lnmp,lnamp等

部分组件的可选安装,如memcache,mysqli,pdo_mysql,innodb等
具体的安装方法可见http://www.wdlinux.cn/bbs/thread-1356-1-1.html

下载安装
wget http://dl.wdlinux.cn:5180/lanmp_v2.3.tar.gz
tar zxvf lanmp_v2.3.tar.gz
安装全部
sh in.sh
可选安装lnamp,lamp,lnmp三个中任一个

wdcp管理系统后台访问地址
http://ip:8080
默认用户密码
admin
wdlinux.cn

mysql默认的用户密码
root
wdlinux.cn

web应用环境切换
如安装好后又想切换到另一环境,可如下操作,但不可重复操作
./tolamp.sh 切换至lamp环境
./tolnmp.sh 切换至lnmp环境
./tolnamp.sh 切换至lnamp环境

安装说明
有比较多的朋友说在安装mysql时会“卡住”,其实不然,只不过是因为mysql的编译时间比较长,10至30分钟不等,具体看机器的硬件配置,所以请耐心等待,但有些是网络中断就真像卡住了一样,到底是不是真卡住,可以看这里的说明
http://www.wdlinux.cn/bbs/thread-65-1-1.html

相关说明
所有软件安装目录/www/wdlinux
站点配置文件
/www/wdlinux/nginx/conf/vhost
/www/wdlinux/apache/conf/vhost

数据库配置文件/www/wdlinux/etc/my.cnf
数据库数据文件目录 /www/wdlinux/mysql/var

卸载或重装(注意备份数据,否则后果自负)
sh in.sh un
即可卸载,并且自动重起
启动完登录后,再次运行
sh in.sh
便可重装
重装后重新打开IE,否则会有session错误提示的问题

相关软件版本
httpd-2.2.22
nginx-1.0.12
php-5.2.17
mysql-5.1.61
phpmyadmin-3.3.7
zend-3.3.3
eAccelerator-0.9.5.3
pure-ftpd-1.0.35

感谢论坛会员itxx对ubuntu系统支持做的大量工作和测试

本文连接 http://www.wdlinux.cn/bbs/thread-2240-1-1.html
作者: itxx    时间: 2012-5-28 10:49

沙发,欢迎各位童鞋测试,如遇任何问题欢迎提出 尽力解答之。
作者: liangwei    时间: 2012-5-28 10:59

给力!!!!
作者: gguan    时间: 2012-5-28 11:03

支持哦!!
作者: looes    时间: 2012-5-28 11:10

是否可以 后台升级
作者: itxx    时间: 2012-5-28 11:53

回复 5# looes

请等待admin哥给回复。
作者: admin    时间: 2012-5-28 12:09

web环境不需要升级,wdcp系统可以在后台升级,不过待发布wdcp的新版后
作者: happytang    时间: 2012-5-28 19:25

支持,LINUX做WEB服务器还是很常见的,稳定快捷,使用lanmp非常爽~
作者: hackeradrian    时间: 2012-5-28 19:46

不错不错
作者: tinhuang    时间: 2012-5-28 22:54

已经在用的怎么用这个新包?老数据会不会有影响(已经存在的站点,数据库,后台设置等)
作者: admin    时间: 2012-5-29 09:01

如果现有的环境也是本站点的一键安装包,则不用操作,因为那些都差不多的
如果不是,则备份好数据可以新安装
作者: tinhuang    时间: 2012-5-29 09:41

本帖最后由 tinhuang 于 2012-5-29 09:58 编辑

现在是lamp(wdlinux),想换成lnamp看效率有没有提升。。。。
作者: 隔壁王二    时间: 2012-5-31 03:02

本帖最后由 隔壁王二 于 2012-5-31 03:05 编辑

在阿里云的VPS上安装不了,阿里云的VPS,数据盘是单独一个虚拟硬盘,我mount /dev/xvdb /www 然后写入/etc/fstab,之后重启,然后下载安装包,解压安装,到了mysql就出错停住了
001.jpg
2012-5-31 03:05


图片附件: 001.jpg (2012-5-31 03:05, 202.82 KB) / 下载次数 348
http://www.wdlinux.cn/bbs/attachment.php?aid=723&k=12344419407b4f8478fee340a6f0755a&t=1537944767&sid=Uuakkf


作者: 隔壁王二    时间: 2012-5-31 04:47

重装系统之后,下载2.2版本的安装包,错误依旧:
002.jpg
2012-5-31 04:47


图片附件: 002.jpg (2012-5-31 04:47, 258.22 KB) / 下载次数 352
http://www.wdlinux.cn/bbs/attachment.php?aid=724&k=12505e71aae6633f7fa4013e321c1db2&t=1537944767&sid=Uuakkf


作者: xy83918    时间: 2012-6-1 00:52

  1. useradd: user 'wdcpu' already exists

  2. installing mysql...
  3. checking build system type... x86_64-unknown-linux-gnu
  4. checking host system type... x86_64-unknown-linux-gnu
  5. checking target system type... x86_64-unknown-linux-gnu
  6. checking for a BSD-compatible install... /usr/bin/install -c
  7. checking whether build environment is sane... yes
  8. checking for a thread-safe mkdir -p... /bin/mkdir -p
  9. checking for gawk... gawk
  10. checking whether make sets $(MAKE)... no
  11. checking how to create a ustar tar archive... gnutar
  12. checking for style of include used by make... none
  13. checking for gcc... no
  14. checking for cc... no
  15. checking for cl.exe... no
  16. configure: error: in `/root/lanmp/mysql-5.1.61':
  17. configure: error: no acceptable C compiler found in $PATH
  18. See `config.log' for more details.


  19. ----Install Error: mysql configure err -----------
复制代码

作者: xy83918    时间: 2012-6-1 01:17

我在网上查是因为没装gcc但安装gcc时出现如下错误
  1. Error: Package: glibc-headers-2.12-1.47.el6_2.12.x86_64 (updates)
  2.            Requires: kernel-headers >= 2.2.1
  3. Error: Package: glibc-headers-2.12-1.47.el6_2.12.x86_64 (updates)
  4.            Requires: kernel-headers
  5. You could try using --skip-broken to work around the problem
  6. ** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
  7. kernel-2.6.32-220.13.1.el6.x86_64 has missing requires of kernel-firmware >= ('0
  8. ', '2.6.32', '220.13.1.el6')
复制代码

作者: admin    时间: 2012-6-1 08:54

http://www.wdlinux.cn/bbs/thread-2287-1-1.html
作者: 夏筱羽    时间: 2012-6-2 00:23

[root@localhost tmp]# tar zxvf lanmp_v2.3.tar.gz
lanmp/
lanmp/RPM-GPG-KEY.dag.txt
lanmp/rpmforge-release-0.5.2-2.el5.rf.x86_64.rpm
lanmp/vsftpd-2.3.4.tar.gz
lanmp/nginx-1.0.12.tar.gz
lanmp/phpmyadmin.tar.gz

gzip: stdin: unexpected end of file
tar: 未預期的保存檔結尾
tar: 未預期的保存檔結尾
tar: Error is not recoverable: exiting now


[root@localhost tmp]# tar zxvf lanmp_v2.2.tar.gz
lanmp/
lanmp/RPM-GPG-KEY.dag.txt
lanmp/rpmforge-release-0.5.2-2.el5.rf.x86_64.rpm
lanmp/vsftpd-2.3.4.tar.gz
lanmp/nginx-1.0.12.tar.gz
lanmp/wdcp_v2.3.tar.gz

gzip: stdin: unexpected end of file
tar: 未預期的保存檔結尾
tar: 未預期的保存檔結尾
tar: Error is not recoverable: exiting now

作者: admin    时间: 2012-6-2 10:12

这个是没有下载完lanmp_v2.3.tar.gz的安装包的原因
作者: admin    时间: 2012-6-5 23:46

configure: error: in `/root/lanmp/mysql-5.1.61':
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.

yum install -y gcc gcc-c++ make autoconf libtool-ltdl-devel gd-devel freetype-devel libxml2-devel libjpeg-devel libpng-devel openssl-devel curl-devel patch libmcrypt-devel libmhash-devel ncurses-devel sudo bzip2

作者: qiuye330    时间: 2012-6-8 15:16

当前版本: wdcp_v2.4.3(20120530) 最新 wdcp_v2.3.3(20120425) 更新
为什么我刚安装的显示这个啊
作者: admin    时间: 2012-6-8 15:34

安装包里是最新的
作者: sunqiangcn    时间: 2012-6-19 11:23

新安装包里面 好像默认安装了eAccelerator因为在侦探里面可以看到       但是后台为什么显示没有安装 求解决
作者: admin    时间: 2012-6-19 12:10

程序与EAC的兼容性问题
作者: sunqiangcn    时间: 2012-6-19 12:15

回复 24# admin


    没安装任何程序啊 就是wd的后台 显示 未安装
作者: admin    时间: 2012-6-19 13:01

WD的后台与WEB前端是不一样的,是两个环境来的
可以不理WD后台里的
作者: 凡高的耳朵    时间: 2012-6-19 18:43

请问为什么我无法下载啊?无法解析下载地址。
作者: admin    时间: 2012-6-19 19:15

哪个无法下载
作者: 凡高的耳朵    时间: 2012-6-19 20:50

哪个无法下载
admin 发表于 2012-6-19 19:15



   [root@CentOS62 ~]# wget http://dl.wdlinux.cn:5180/lanmp_v2.3.tar.gz--2012-06-19 20:44:36--  http://dl.wdlinux.cn:5180/lanmp_v2.3.tar.gz
正在解析主机 dl.wdlinux.cn... 失败:域名解析暂时失败。
wget: 无法解析主机地址 “dl.wdlinux.cn”
[root@CentOS62 ~]#
作者: admin    时间: 2012-6-19 22:17

那下机器的DNS
作者: czd327917086    时间: 2012-6-22 19:40

我看nginx官方1.0里面只有1.0.15下载,是不是1.0.12没1.0.15稳定?
作者: mingwd    时间: 2012-6-23 09:53

这个 ……昨晚看有2.4了,怎么还是2.3啊




欢迎光临 WDlinux官方论坛 (http://www.wdlinux.cn/bbs/) Powered by Discuz! 7.2