Board logo

标题: [发布] lanmp一键包软件版本升级脚本及说明 [打印本页]

作者: admin    时间: 2012-3-20 19:10     标题: lanmp一键包软件版本升级脚本及说明

虽然个人觉得,应用环境一般安装好就不用升级,除非出现问题或程序出漏洞等,就有必要升级了
但为满足想升级的朋友,这里也会给出一些升级脚本,可以让自行选择是否升级了

版本升级
nginx的升级,当前最新稳定版本是1.0.14
wget http://down.wdlinux.cn/in/nginx_up.sh
sh nginx_up.sh
默认升级是1.0.14,如要指定版本,执行脚本后台加上版本号就可以,如
sh nginx_up.sh 1.0.12
就是只升级到1.0.12版本了

lanmp_v2.4/wdcp_v2.4开始,支持lamp,lnmp,lnamp可自由切换
如果之前的版本,也想切换,升级一下就可以
wget http://dl.wdlinux.cn:5180/lanmp_v2.4.tar.gz
tar zxvf lanmp_v2.4.tar.gz
chmod 755 lanmp_up.sh
./lanmp_up.sh
顺利的话,执行完就可以了升级后lamp,lnmp,lnamp可自由切换

如不行或有错误,把错误信息,贴到论坛上来

2.4以下的,环境切换
wget http://dl.wdlinux.cn:5180/lanmp_v2.4.tar.gz
tar zxvf lanmp_v2.4.tar.gz
chmod 755 tolamp.sh tolnmp.sh tolnamp.sh
./tolamp.sh 切换至lamp环境
./tolnmp.sh 切换至lnmp环境
./tolnamp.sh 切换至lnamp环境
根据实际选择操作

更多的升级脚本,后续会放出
作者: xinzol    时间: 2012-3-21 02:08

我的也是升级后无法打开网站

我也升级了 升级到1.0.14打不开网站了!

管理面板能正常打开!


这个是SSL里面的提示


作者: freemansxh    时间: 2012-3-22 16:46

看来升级还是要慎重啊
作者: pceit    时间: 2012-6-26 19:57

为了安全还是要升级啊
作者: cnsqmy    时间: 2012-6-27 21:49

管理员一人的力量解决不了大家这些问题的
作者: 海阔天空    时间: 2012-7-3 12:52

QQ截图20120703124800.png
2012-7-3 12:52

卡住不动了

图片附件: QQ截图20120703124800.png (2012-7-3 12:52, 17.91 KB) / 下载次数 2906
http://www.wdlinux.cn/bbs/attachment.php?aid=880&k=ddfe82bed3df406ea5b4629a6224fa7e&t=1675276334&sid=PTUArp


作者: dnailccy    时间: 2012-8-27 19:29

脚本里下载的连接都失效了呀。
作者: admin    时间: 2012-8-27 21:23

哪个失效了?
作者: qq682907    时间: 2012-11-11 12:50

回复 1# admin


   --/ 我看了下脚本 原来是没有cache模块  怎么加上啊
作者: jordansko    时间: 2012-12-9 23:18

本帖最后由 jordansko 于 2012-12-9 23:19 编辑

checking for PCRE library in /opt/local/ ... not found

./configure: error: the HTTP rewrite module requires the PCRE library.
You can either disable the module by using --without-http_rewrite_module
option, or install the PCRE library into the system, or build the PCRE library
statically from the source with nginx by using --with-pcre=<path> option.

configure err

老大,nginx的升级 提示这个请问是升级有成功吗
作者: admin    时间: 2012-12-10 10:29

没成功

执行
wget http://down.wdlinux.cn/in/pcre_ins.sh
sh pcre_ins.sh
然后再运行一次安装试试
作者: jordansko    时间: 2012-12-11 18:26

老大,按你下面的方法试了可以了,谢谢老大
作者: noo    时间: 2012-12-21 20:08

回复 1# admin


   老大,出个2.5.4的一键安装包吧。。。
作者: admin    时间: 2012-12-22 12:12

用编译安装的就可以了
作者: esme    时间: 2013-1-22 23:43

怎样用更高级的软件版本直接替换安装包里的版本呢,比如php5.4.11直接替换php5.2.17,mysql5.5.29直接替换mysql5.1.63
作者: admin    时间: 2013-1-23 09:10

回复 15# esme

可以替换试试,不过新版本,可能会有一些调整过的编译参数
作者: esme    时间: 2013-1-23 21:39

我调整了编译参数,安装正常完成,但无法打开面板,打开显示:“WATWDCPM?oÆmñ‰[4kñ)¸6 õñ'3‹er87ˆvi¸*D‰Q}ËM/|m£_&*uvHj¤miÕáà¨ÕTŠTË°üGvÇVŒ”
作者: admin    时间: 2013-1-23 22:47

这个是wdcp安装有问题

还调整了其它吧
作者: esme    时间: 2013-1-24 12:30

回复 18# admin



我看了下安装脚本,震惊了,wdcp自身程序和网站环境居然用的是两套php 和 apache,这样既浪费服务器磁盘空间,又浪费服务器内存,安装起来时间也长,为什么不能和二为一呢?

研究了很久终于找到问题所在!
由于wdcp自身程序的环境默认的是php 5.2.17,所以php_wdcpm.so这个module是php 5.2.17版本的,和最新的php 5.4.11自然不兼容。
请问能提供php 5.4.11版本的php_wdcpm.so么?谢谢
作者: wulali    时间: 2013-1-24 12:45

本帖最后由 wulali 于 2013-1-24 12:57 编辑
回复  admin



我看了下安装脚本,震惊了,wdcp自身程序和网站环境居然用的是两套php 和 apache,这样 ...
esme 发表于 2013-1-24 12:30


本来就是这样的,1.X版本时倒是只有一套的,2.X分成两套是为了进行一些操作时,使得在前台关闭或发生错误的情况下,后台能继续操作
话说你干嘛要将后台的PHP版本也升级?后台的PHP继续用原来的PHP 5.2.17,前台用PHP 5.4.11不就好了
在lanmp.sh里把PHP_VER="5.2.17"修改成你想升级的版本,并修改一些编译参数,然后把PHP5.4的源代码压缩包放到lanmp文件夹下即可

话说你其实不必采用替换压缩包的方式,将新版本的压缩包放到lanmp文件夹下,然后修改lanmp.sh里的各种程序版本号即可(比如MYS_VER、PHP_VER等等)
后台的相关程序版本就不必升级了(p.s: 后台的apache用的好像是2.0.64)
作者: admin    时间: 2013-1-24 19:22

楼上的说得很好
作者: esme    时间: 2013-1-25 13:40

晕倒,多次尝试修改脚本直接内置最新的mysql5.5.29失败,安装完访问wdcp总是显示:无法连接mysql,请检查mysql是否已启动及用户密码是否设置正确!:

强烈建议官方出一个内置mysql 5.5.29和php 5.4.11的版本,另外pureftp和eaccelerator都有最新版了,这个自己集成倒是很容易,我已经做到
作者: danets    时间: 2016-3-29 10:26

为了安全还是要升级啊




欢迎光临 WDlinux官方论坛 (http://www.wdlinux.cn/bbs/) Powered by Discuz! 7.2