无标题文档
wdCP系统 (介绍,功能特性,运行环境,安装说明,演示,常见问题,使用教程) wdCDN系统 (介绍,功能特性,运行环境,安装说明,演示,常见问题,使用手册)
wdOS系统 (介绍,功能特性,运行环境,安装说明,演示,常见问题,使用教程) wdDNS系统 (介绍,功能特性,运行环境,安装说明,演示,常见问题,使用手册)
注册 发贴 提问 回复-必看必看 wddns免费智能 DNS 开通 本地或虚拟机使 用wdcp 一键包在mysql编 译时"卡住"
【300G高防】双线 无视攻击 wdcp官方技术支持/服务 阿里云8折优惠券 无敌云 腾讯云优惠中,现注册更有260代金额券赠送
返回列表 发帖
提问三步曲: 提问先看教程/FAQ索引(wdcp,wdcp_v3,一键包)及搜索,会让你更快解决问题
1 提供详细,如系统版本,wdcp版本,软件版本等及错误的详细信息,贴上论坛或截图发论坛
2 做过哪些操作或改动设置等

温馨提示:信息不详,很可能会没人理你!论坛有教程说明的,也可能没人理!因为,你懂的

[求助] 阿里云主机,centos 5.4 多次安装最新的2.2均不成功

全新安装的时候,install Error :mysql configure errr
1.jpg
2012-3-11 14:50


然后在下面键入
  1. yum install -y gcc gcc-c++ make autoconf libtool-ltdl-devel gd-devel freetype-devel libxml2-devel libjpeg-devel libpng-devel openssl-devel curl-devel patch libmcrypt-devel libmhash-devel ncurses-devel sudo bzip2
复制代码


然后出现
  1. ---> Package libstdc++-devel.i386 0:4.1.2-52.el5 set to be updated
  2. http://mirror.centos.org/centos/5/addons/i386/repodata/filelists.xml.gz: [Errno 12] Timeout: <urlopen error timed out>
  3. Trying other mirror.
  4. Error: failure: repodata/filelists.xml.gz from addons: [Errno 256] No more mirrors to try.
  5. You could try using --skip-broken to work around the problem
  6. You could try running: package-cleanup --problems
  7. package-cleanup --dupes
  8. rpm -Va --nofiles --nodigest
  9. The program package-cleanup is found in the yum-utils package.
  10. You have new mail in /var/spool/mail/root
复制代码


2.JPG
2012-3-11 14:54


重新安装还是出现最面的那个错误,install Error :mysql configure errr,也把
  1. 登陆SSH,编辑下:/etc/yum/pluginconf.d/fastestmirror.conf

  2. vi /etc/yum/pluginconf.d/fastestmirror.conf

  3.   把enabled=1改成enabled=0

  4. [main]
  5. enabled=0
  6. verbose=0
  7. socket_timeout=3
  8. hostfilepath=/var/cache/yum/timedhosts.txt
  9. maxhostfileage=10
  10. maxthreads=15
  11. #exclude=.gov, facebook
复制代码


这个做了

。。。。。。。。。。。。。。
www.fsbbs.net

TOP

本帖最后由 阿飞刘 于 2012-3-11 16:17 编辑

  1. ---> Package libXpm-devel.i386 0:3.5.5-3 set to be updated
  2. ---> Package libgcc.i386 0:4.1.2-52.el5 set to be updated
  3. ---> Package libgomp.i386 0:4.4.6-3.el5.1 set to be updated
  4. ---> Package libidn-devel.i386 0:0.6.5-1.1 set to be updated
  5. ---> Package libmcrypt.i386 0:2.5.8-4.el5.centos set to be updated
  6. ---> Package libpng.i386 2:1.2.10-15.el5_7 set to be updated
  7. ---> Package libstdc++.i386 0:4.1.2-52.el5 set to be updated
  8. ---> Package libstdc++-devel.i386 0:4.1.2-52.el5 set to be updated
  9. addons/filelists                                         |  180 B     00:00     
  10. http://mirror.centos.org/centos/5/addons/i386/repodata/filelists.xml.gz: [Errno -1] Metadata file does not match checksum
  11. Trying other mirror.
  12. Error: failure: repodata/filelists.xml.gz from addons: [Errno 256] No more mirrors to try.
  13. You could try using --skip-broken to work around the problem
  14. You could try running: package-cleanup --problems
  15.                         package-cleanup --dupes
  16.                         rpm -Va --nofiles --nodigest
  17. The program package-cleanup is found in the yum-utils package.
  18. 11 Mar 16:11:12 ntpdate[2330]: the NTP socket is in use, exiting
  19. setenforce: SELinux is disabled
  20. Stopping httpd:                                            [FAILED]
  21. mysqld: unrecognized service
  22. error reading information on service mysqld: No such file or directory
  23. installing mysql...
  24. checking build system type... i686-pc-linux-gnu
  25. checking host system type... i686-pc-linux-gnu
  26. checking target system type... i686-pc-linux-gnu
  27. checking for a BSD-compatible install... /usr/bin/install -c
  28. checking whether build environment is sane... yes
  29. checking for a thread-safe mkdir -p... /bin/mkdir -p
  30. checking for gawk... gawk
  31. checking whether make sets $(MAKE)... yes
  32. checking how to create a ustar tar archive... gnutar
  33. checking for style of include used by make... GNU
  34. checking for gcc... no
  35. checking for cc... no
  36. checking for cl.exe... no
  37. configure: error: in `/root/lanmp/mysql-5.1.61':
  38. configure: error: no acceptable C compiler found in $PATH
  39. See `config.log' for more details.

  40. ----Install Error: mysql configure err -----------

  41. PING www.wdlinux.cn (113.105.167.213) 56(84) bytes of data.
  42. From ip223.hichina.com (223.4.31.251) icmp_seq=1 Time to live exceeded
  43. --- www.wdlinux.cn ping statistics ---
  44. 1 packets transmitted, 0 received, +1 errors, 100% packet loss, time 0ms
  45. Preparing...                ########################################### [100%]
  46. package rpmforge-release-0.5.2-2.el5.rf.i386 is already installed
  47. Loaded plugins: fastestmirror
  48. Loading mirror speeds from cached hostfile
  49. * base: mirrors.163.com
  50. * extras: mirrors.163.com
  51. * rpmforge: fr2.rpmfind.net
  52. * updates: mirrors.163.com
  53. Setting up Install Process
  54. Package 1:make-3.81-3.el5.i386 already installed and latest version
  55. Resolving Dependencies
  56. --> Running transaction check
  57. ---> Package autoconf.noarch 0:2.59-12 set to be updated
  58. --> Processing Dependency: imake for package: autoconf
  59. ---> Package bzip2.i386 0:1.0.3-6.el5_5 set to be updated
  60. ---> Package curl-devel.i386 0:7.15.5-15.el5 set to be updated
  61. --> Processing Dependency: curl = 7.15.5-15.el5 for package: curl-devel
  62. --> Processing Dependency: libidn-devel for package: curl-devel
  63. ---> Package freetype-devel.i386 0:2.2.1-28.el5_7.2 set to be updated
  64. --> Processing Dependency: freetype = 2.2.1-28.el5_7.2 for package: freetype-devel
  65. --> Processing Dependency: zlib-devel for package: freetype-devel
  66. ---> Package gcc.i386 0:4.1.2-52.el5 set to be updated
  67. --> Processing Dependency: cpp = 4.1.2-52.el5 for package: gcc
  68. --> Processing Dependency: libgomp >= 4.1.2-52.el5 for package: gcc
  69. --> Processing Dependency: libgcc >= 4.1.2-52.el5 for package: gcc
  70. --> Processing Dependency: glibc-devel >= 2.2.90-12 for package: gcc
  71. ---> Package gcc-c++.i386 0:4.1.2-52.el5 set to be updated
  72. --> Processing Dependency: libstdc++-devel = 4.1.2-52.el5 for package: gcc-c++
  73. --> Processing Dependency: libstdc++ = 4.1.2-52.el5 for package: gcc-c++
  74. ---> Package gd-devel.i386 0:2.0.33-9.4.el5_4.2 set to be updated
  75. --> Processing Dependency: gd = 2.0.33-9.4.el5_4.2 for package: gd-devel
  76. --> Processing Dependency: libXpm-devel for package: gd-devel
  77. --> Processing Dependency: libX11-devel for package: gd-devel
  78. --> Processing Dependency: fontconfig-devel for package: gd-devel
  79. ---> Package libcap-devel.i386 0:1.10-26 set to be updated
  80. ---> Package libjpeg-devel.i386 0:6b-37 set to be updated
  81. ---> Package libmcrypt-devel.i386 0:2.5.8-4.el5.centos set to be updated
  82. --> Processing Dependency: libmcrypt = 2.5.8-4.el5.centos for package: libmcrypt-devel
  83. --> Processing Dependency: libmcrypt.so.4 for package: libmcrypt-devel
  84. ---> Package libpng-devel.i386 2:1.2.10-15.el5_7 set to be updated
  85. --> Processing Dependency: libpng = 2:1.2.10-15.el5_7 for package: libpng-devel
  86. ---> Package libtool-ltdl-devel.i386 0:1.5.22-7.el5_4 set to be updated
  87. --> Processing Dependency: libtool-ltdl = 1.5.22-7.el5_4 for package: libtool-ltdl-devel
  88. ---> Package libxml2-devel.i386 0:2.6.26-2.1.15.el5_8.2 set to be updated
  89. ---> Package mhash-devel.i386 0:0.9.9-1.el5.rf set to be updated
  90. --> Processing Dependency: mhash = 0.9.9-1.el5.rf for package: mhash-devel
  91. --> Processing Dependency: libmhash.so.2 for package: mhash-devel
  92. ---> Package ncurses-devel.i386 0:5.5-24.20060715 set to be updated
  93. ---> Package ntp.i386 0:4.2.2p1-15.el5.centos.1 set to be updated
  94. ---> Package openssl-devel.i386 0:0.9.8e-22.el5 set to be updated
  95. --> Processing Dependency: openssl = 0.9.8e-22.el5 for package: openssl-devel
  96. --> Processing Dependency: krb5-devel for package: openssl-devel
  97. ---> Package patch.i386 0:2.5.4-31.el5 set to be updated
  98. ---> Package sudo.i386 0:1.7.2p1-13.el5 set to be updated
  99. ---> Package sysklogd.i386 0:1.4.1-46.el5 set to be updated
  100. --> Running transaction check
  101. ---> Package cpp.i386 0:4.1.2-52.el5 set to be updated
  102. ---> Package curl.i386 0:7.15.5-15.el5 set to be updated
  103. ---> Package fontconfig-devel.i386 0:2.4.1-7.el5 set to be updated
  104. ---> Package freetype.i386 0:2.2.1-28.el5_7.2 set to be updated
  105. ---> Package gd.i386 0:2.0.33-9.4.el5_4.2 set to be updated
  106. ---> Package glibc-devel.i386 0:2.5-81 set to be updated
  107. --> Processing Dependency: glibc-headers = 2.5-81 for package: glibc-devel
  108. --> Processing Dependency: glibc = 2.5-81 for package: glibc-devel
  109. --> Processing Dependency: glibc-headers for package: glibc-devel
  110. ---> Package imake.i386 0:1.0.2-3 set to be updated
  111. ---> Package krb5-devel.i386 0:1.6.1-70.el5 set to be updated
  112. --> Processing Dependency: krb5-libs = 1.6.1-70.el5 for package: krb5-devel
  113. --> Processing Dependency: libselinux-devel for package: krb5-devel
  114. --> Processing Dependency: e2fsprogs-devel for package: krb5-devel
  115. --> Processing Dependency: keyutils-libs-devel for package: krb5-devel
  116. ---> Package libX11-devel.i386 0:1.0.3-11.el5_7.1 set to be updated
  117. --> Processing Dependency: libX11 = 1.0.3-11.el5_7.1 for package: libX11-devel
  118. --> Processing Dependency: xorg-x11-proto-devel >= 7.1-2 for package: libX11-devel
  119. --> Processing Dependency: libXau-devel for package: libX11-devel
  120. --> Processing Dependency: libXdmcp-devel for package: libX11-devel
  121. ---> Package libXpm-devel.i386 0:3.5.5-3 set to be updated
  122. ---> Package libgcc.i386 0:4.1.2-52.el5 set to be updated
  123. ---> Package libgomp.i386 0:4.4.6-3.el5.1 set to be updated
  124. ---> Package libidn-devel.i386 0:0.6.5-1.1 set to be updated
  125. ---> Package libmcrypt.i386 0:2.5.8-4.el5.centos set to be updated
  126. ---> Package libpng.i386 2:1.2.10-15.el5_7 set to be updated
  127. ---> Package libstdc++.i386 0:4.1.2-52.el5 set to be updated
  128. ---> Package libstdc++-devel.i386 0:4.1.2-52.el5 set to be updated
  129. http://mirror.centos.org/centos/5/addons/i386/repodata/filelists.xml.gz: [Errno 12] Timeout: <urlopen error timed out>
  130. Trying other mirror.
  131. Error: failure: repodata/filelists.xml.gz from addons: [Errno 256] No more mirrors to try.
  132. You could try using --skip-broken to work around the problem
  133. You could try running: package-cleanup --problems
  134.                         package-cleanup --dupes
  135.                         rpm -Va --nofiles --nodigest
  136. The program package-cleanup is found in the yum-utils package.
  137. 11 Mar 16:12:15 ntpdate[2645]: the NTP socket is in use, exiting
  138. setenforce: SELinux is disabled
  139. installing mysql...
  140. checking build system type... i686-pc-linux-gnu
  141. checking host system type... i686-pc-linux-gnu
  142. checking target system type... i686-pc-linux-gnu
  143. checking for a BSD-compatible install... /usr/bin/install -c
  144. checking whether build environment is sane... yes
  145. checking for a thread-safe mkdir -p... /bin/mkdir -p
  146. checking for gawk... gawk
  147. checking whether make sets $(MAKE)... yes
  148. checking how to create a ustar tar archive... gnutar
  149. checking for style of include used by make... GNU
  150. checking for gcc... no
  151. checking for cc... no
  152. checking for cl.exe... no
  153. configure: error: in `/root/lanmp/mysql-5.1.61':
  154. configure: error: no acceptable C compiler found in $PATH
  155. See `config.log' for more details.

  156. ----Install Error: mysql configure err -----------
复制代码

TOP

DNS错误,域名解释不了
所以
yum install -y gcc gcc-c++ make autoconf libtool-ltdl-devel gd-devel freetype-devel libxml2-devel libjpeg-devel libpng-devel openssl-devel curl-devel patch libmcrypt-devel libmhash-devel ncurses-devel sudo bzip2
这个也没更新成功
看清提问三步曲及多看教程/FAQ索引(wdcp,v3,一键包,wdOS),益处多多.wdcp工具集 阿里云主机8折优惠码

TOP

那怎么解决

TOP

换一个DNS
看清提问三步曲及多看教程/FAQ索引(wdcp,v3,一键包,wdOS),益处多多.wdcp工具集 阿里云主机8折优惠码

TOP

换虚拟主机的dns?

TOP

我有一台5.4的也是这个问题。不理解咋 回事

TOP

DNS不行,所以域名解析不了,所以yum更新不成功,所以没有相关的依懒包和库,所以安装不成功

可以换一个DNS试试,可以看/etc/resolv.conf这个文件
看清提问三步曲及多看教程/FAQ索引(wdcp,v3,一键包,wdOS),益处多多.wdcp工具集 阿里云主机8折优惠码

TOP

云主机可以重置下

TOP

返回列表