无标题文档
WDCDN联

盟内部测试火热进行中
wdCP系统 (介绍,功能特性,运行环境,安装说明,演示,常见问题,使用教程) wdCDN系统 (介绍,功能特性,运行环境,安装说明,演示,常见问题,使用手册)
wdOS系统 (介绍,功能特性,运行环境,安装说明,演示,常见问题,使用教程) wdDNS系统 (介绍,功能特性,运行环境,安装说明,演示,常见问题,使用手册)
注册 发贴 提问 回复-必看必看 wddns免费智能 DNS 开通 本地或虚拟机使 用wdcp 一键包在mysql编 译时"卡住"
【300G高防】双线 无视攻击 wdcp官方技术支持/服务 阿里云8折优惠券 无敌云 腾讯云优惠中,现注册更有260代金额券赠送
返回列表 发帖
提问三步曲: 提问先看教程/FAQ索引(wdcp,wdcp_v3,一键包)及搜索,会让你更快解决问题
1 提供详细,如系统版本,wdcp版本,软件版本等及错误的详细信息,贴上论坛或截图发论坛
2 做过哪些操作或改动设置等

温馨提示:信息不详,很可能会没人理你!论坛有教程说明的,也可能没人理!因为,你懂的
我安装这个帖子做了相应升级,都成功了。然后我按照以下方法增加pdo-mysql,安装成功,也没报错,就是安装程序时,还是提示缺少这个模块。 之前是nginx+ap,我后台换成了ap后再添加模块的!

wget http://pecl.php.net/get/PDO_MYSQL-1.0.2.tgz
tar zxvf PDO_MYSQL-1.0.2.tgz
cd PDO_MYSQL-1.0.2
/www/wdlinux/php/bin/phpize
./configure --with-php-config=/www/wdlinux/php/bin/php-config --with-pdo-mysql=/www/wdlinux/mysql
make
make install

增加到配置文件里
# vi /www/wdlinux/etc/php.ini
在最后加入
extension=pdo_mysql.so

然后重起web服务,如
service httpd restart
service nginxd restart
E域男 eyunan.com

TOP

本帖最后由 wulali 于 2013-1-26 18:07 编辑
我安装这个帖子做了相应升级,都成功了。然后我按照以下方法增加pdo-mysql,安装成功,也没报错,就是安装程 ...
eyunan 发表于 2013-1-26 18:02

检查一下php.ini里的有没有extension_dir=/www/wdlinux/php/lib/php/extensions/no-debug-non-zts-20090626这句
没有的话,加上或者修改一下,然后重启web服务即可

TOP

我安装这个帖子做了相应升级,都成功了。然后我按照以下方法增加pdo-mysql,安装成功,也没报错,就是安装程序时,还是提示缺少这个模块。 之前是nginx+ap,我后台换成了ap后再添加模块的!

wget http://pecl.php.net/get/PDO_MYSQL-1.0.2.tgz
tar zxvf PDO_MYSQL-1.0.2.tgz
cd PDO_MYSQL-1.0.2
/www/wdlinux/php/bin/phpize
./configure --with-php-config=/www/wdlinux/php/bin/php-config --with-pdo-mysql=/www/wdlinux/mysql
make
make install

增加到配置文件里
# vi /www/wdlinux/etc/php.ini
在最后加入
extension=pdo_mysql.so

然后重起web服务,如
service httpd restart
service nginxd restart
E域男 eyunan.com

TOP

我安装这个帖子做了相应升级,都成功了。然后我按照以下方法增加pdo-mysql,安装成功,也没报错,就是安装程序时,还是提示缺少这个模块。 之前是nginx+ap,我后台换成了ap后再添加模块的!

wget http://pecl.php.net/get/PDO_MYSQL-1.0.2.tgz
tar zxvf PDO_MYSQL-1.0.2.tgz
cd PDO_MYSQL-1.0.2
/www/wdlinux/php/bin/phpize
./configure --with-php-config=/www/wdlinux/php/bin/php-config --with-pdo-mysql=/www/wdlinux/mysql
make
make install

增加到配置文件里
# vi /www/wdlinux/etc/php.ini
在最后加入
extension=pdo_mysql.so

然后重起web服务,如
service httpd restart
service nginxd restart
E域男 eyunan.com

TOP

我安装这个帖子做了相应升级,都成功了。然后我按照以下方法增加pdo-mysql,安装成功,也没报错,就是安装程序时,还是提示缺少这个模块。 之前是nginx+ap,我后台换成了ap后再添加模块的!

wget http://pecl.php.net/get/PDO_MYSQL-1.0.2.tgz
tar zxvf PDO_MYSQL-1.0.2.tgz
cd PDO_MYSQL-1.0.2
/www/wdlinux/php/bin/phpize
./configure --with-php-config=/www/wdlinux/php/bin/php-config --with-pdo-mysql=/www/wdlinux/mysql
make
make install

增加到配置文件里
# vi /www/wdlinux/etc/php.ini
在最后加入
extension=pdo_mysql.so

然后重起web服务,如
E域男 eyunan.com

TOP

我安装这个帖子做了相应升级,都成功了。然后我按照以下方法增加pdo-mysql,安装成功,也没报错,就是安装程序时,还是提示缺少这个模块。 之前是nginx+ap,我后台换成了ap后再添加模块的!

wget http://pecl.php.net/get/PDO_MYSQL-1.0.2.tgz
tar zxvf PDO_MYSQL-1.0.2.tgz
cd PDO_MYSQL-1.0.2
/www/wdlinux/php/bin/phpize
./configure --with-php-config=/www/wdlinux/php/bin/php-config --with-pdo-mysql=/www/wdlinux/mysql
make
make install

增加到配置文件里
# vi /www/wdlinux/etc/php.ini
在最后加入
extension=pdo_mysql.so

然后重起web服务,如
E域男 eyunan.com

TOP

我安装这个帖子做了相应升级,都成功了。然后我按照以下方法增加pdo-mysql,安装成功,也没报错,就是安装程序时,还是提示缺少这个模块。 之前是nginx+ap,我后台换成了ap后再添加模块的!

wget http:// pecl.php.net/get/PDO_MYSQL-1.0.2.tgz
tar zxvf PDO_MYSQL-1.0.2.tgz
cd PDO_MYSQL-1.0.2
/www/wdlinux/php/bin/phpize
./configure --with-php-config=/www/wdlinux/php/bin/php-config --with-pdo-mysql=/www/wdlinux/mysql
make
make install

增加到配置文件里
# vi /www/wdlinux/etc/php.ini
在最后加入
extension=pdo_mysql.so

然后重起web服务,如
E域男 eyunan.com

TOP

电脑卡,点发表,一次发了这么多。
E域男 eyunan.com

TOP

回复 62# wulali


    好的,我试试,谢谢!
E域男 eyunan.com

TOP

回复 62# wulali


    有这么一句,也不行呢!
[Zend]
zend_extension = /www/wdlinux/Zend/lib/ZendGuardLoader.so
zend_loader.enable = 1
[eaccelerator]
extension_dir="/www/wdlinux/nginx_php/lib/php/extensions/no-debug-non-zts-20090626/"
extension="eaccelerator.so"
eaccelerator.shm_size="8"
eaccelerator.cache_dir="/www/wdlinux/eaccelerator_cache"
eaccelerator.enable="1"
eaccelerator.optimizer="1"
eaccelerator.check_mtime="1"
eaccelerator.debug="0"
eaccelerator.filter=""
eaccelerator.shm_max="0"
eaccelerator.shm_ttl="3600"
eaccelerator.shm_prune_period="3600"
eaccelerator.shm_only="0"
eaccelerator.compress="1"
eaccelerator.compress_level="9"
extension=pdo_mysql.so
E域男 eyunan.com

TOP

回复  wulali


    有这么一句,也不行呢!
[Zend]
zend_extension = /www/wdlinux/Zend/lib/ZendGu ...
eyunan 发表于 2013-1-26 18:29

你不是用apache吗?怎么extensions的目录写的是ngnix的PHP?
应该用extension_dir=/www/wdlinux/php/lib/php/extensions/no-debug-non-zts-20090626

TOP

我换成了nginx 重新弄得。 我试试 把nginx_php 换成 php ,nginx_php 是我重新安装后系统自己默认的!
E域男 eyunan.com

TOP

回复 71# wulali


    还是不行 无效
E域男 eyunan.com

TOP

本帖最后由 wulali 于 2013-1-26 19:35 编辑
我换成了nginx 重新弄得。 我试试 把nginx_php 换成 php ,nginx_php 是我重新安装后系统自己默认的!
eyunan 发表于 2013-1-26 18:47

你编译模块的时候用的是哪个?
你是不是切换为apache时编译模块的?那么你切换成ngnix时要再重新编译了(因为你只给apache的PHP添加了模块)
你可以看看/www/wdlinux/php/lib/php/extensions/no-debug-non-zts-20090626文件夹下有没有pdo_mysql.so这个文件?
p.s: 用A+N时,PHP用的是apache的PHP

TOP

回复 12# ngibo1278


   我需要的mysql升级 居然在你的回复里 看到了  你的问题解决了没

TOP

返回列表