无标题文档
WDCDN联

盟内部测试火热进行中
wdCP系统 (介绍,功能特性,运行环境,安装说明,演示,常见问题,使用教程) wdCDN系统 (介绍,功能特性,运行环境,安装说明,演示,常见问题,使用手册)
wdOS系统 (介绍,功能特性,运行环境,安装说明,演示,常见问题,使用教程) wdDNS系统 (介绍,功能特性,运行环境,安装说明,演示,常见问题,使用手册)
注册 发贴 提问 回复-必看必看 wddns免费智能 DNS 开通 本地或虚拟机使 用wdcp 一键包在mysql编 译时"卡住"
【300G高防】双线 无视攻击 wdcp官方技术支持/服务 阿里云8折优惠券 无敌云 腾讯云优惠中,现注册更有260代金额券赠送
返回列表 发帖
提问三步曲: 提问先看教程/FAQ索引(wdcp,wdcp_v3,一键包)及搜索,会让你更快解决问题
1 提供详细,如系统版本,wdcp版本,软件版本等及错误的详细信息,贴上论坛或截图发论坛
2 做过哪些操作或改动设置等

温馨提示:信息不详,很可能会没人理你!论坛有教程说明的,也可能没人理!因为,你懂的

[发布] lanmp一键包软件版本升级脚本及说明

虽然个人觉得,应用环境一般安装好就不用升级,除非出现问题或程序出漏洞等,就有必要升级了
但为满足想升级的朋友,这里也会给出一些升级脚本,可以让自行选择是否升级了

版本升级
nginx的升级,当前最新稳定版本是1.0.14
wget http://down.wdlinux.cn/in/nginx_up.sh
sh nginx_up.sh
默认升级是1.0.14,如要指定版本,执行脚本后台加上版本号就可以,如
sh nginx_up.sh 1.0.12
就是只升级到1.0.12版本了

lanmp_v2.4/wdcp_v2.4开始,支持lamp,lnmp,lnamp可自由切换
如果之前的版本,也想切换,升级一下就可以
wget http://dl.wdlinux.cn:5180/lanmp_v2.4.tar.gz
tar zxvf lanmp_v2.4.tar.gz
chmod 755 lanmp_up.sh
./lanmp_up.sh
顺利的话,执行完就可以了升级后lamp,lnmp,lnamp可自由切换

如不行或有错误,把错误信息,贴到论坛上来

2.4以下的,环境切换
wget http://dl.wdlinux.cn:5180/lanmp_v2.4.tar.gz
tar zxvf lanmp_v2.4.tar.gz
chmod 755 tolamp.sh tolnmp.sh tolnamp.sh
./tolamp.sh 切换至lamp环境
./tolnmp.sh 切换至lnmp环境
./tolnamp.sh 切换至lnamp环境
根据实际选择操作

更多的升级脚本,后续会放出
看清提问三步曲及多看教程/FAQ索引(wdcp,v3,一键包,wdOS),益处多多.wdcp工具集 阿里云主机8折优惠码

我的也是升级后无法打开网站

我也升级了 升级到1.0.14打不开网站了!

管理面板能正常打开!


这个是SSL里面的提示

TOP

看来升级还是要慎重啊

TOP

为了安全还是要升级啊

TOP

管理员一人的力量解决不了大家这些问题的

TOP

QQ截图20120703124800.png
2012-7-3 12:52

卡住不动了

TOP

脚本里下载的连接都失效了呀。
xxx

TOP

哪个失效了?
看清提问三步曲及多看教程/FAQ索引(wdcp,v3,一键包,wdOS),益处多多.wdcp工具集 阿里云主机8折优惠码

TOP

回复 1# admin


   --/ 我看了下脚本 原来是没有cache模块  怎么加上啊

TOP

本帖最后由 jordansko 于 2012-12-9 23:19 编辑

checking for PCRE library in /opt/local/ ... not found

./configure: error: the HTTP rewrite module requires the PCRE library.
You can either disable the module by using --without-http_rewrite_module
option, or install the PCRE library into the system, or build the PCRE library
statically from the source with nginx by using --with-pcre=<path> option.

configure err

老大,nginx的升级 提示这个请问是升级有成功吗

TOP

没成功

执行
wget http://down.wdlinux.cn/in/pcre_ins.sh
sh pcre_ins.sh
然后再运行一次安装试试
看清提问三步曲及多看教程/FAQ索引(wdcp,v3,一键包,wdOS),益处多多.wdcp工具集 阿里云主机8折优惠码

TOP

老大,按你下面的方法试了可以了,谢谢老大

TOP

回复 1# admin


   老大,出个2.5.4的一键安装包吧。。。

TOP

用编译安装的就可以了
看清提问三步曲及多看教程/FAQ索引(wdcp,v3,一键包,wdOS),益处多多.wdcp工具集 阿里云主机8折优惠码

TOP

怎样用更高级的软件版本直接替换安装包里的版本呢,比如php5.4.11直接替换php5.2.17,mysql5.5.29直接替换mysql5.1.63

TOP

返回列表