Board logo

标题: [发布] wdCP v3正式版发布了 [打印本页]

作者: admin    时间: 2016-4-12 10:18     标题: wdCP v3正式版发布了

---
已更新至3.0.3
---
经过近期的努力,wdCP_v3正式版终于可以和大家见面了

v3功能预览
1 底层完全重新架构,更安全稳定,省资源更高效
2 安装更简单,快速与方便
3 功能更强大和易扩展,且完美支持API的调用
4 系统兼容性更好
5 模板设计更简单容易

安装更简单快速,如只安装v3后台,二分钟即可完成
支持API调用,通过API可结合现有业务系统,实现自助开通等服务
wdCP坚持以简单,方便,易用实用,高效为主
新版将会更省资源,更稳定,易扩展

wdCP介绍
wdCP是WDlinux Control Panel的简称
是一套通过WEB界面就可以控制和管理Linux云主机服务器以及虚拟主机的管理系统
旨在易于使用Linux系统做为我们的网站服务器系统,以及平时对Linux服务器的常用管理操作
均可在wdCP的WEB后台里操作就可以完成.
使用wdCP,通过WEB方式就可以查看服务器情况,资源利用率,系统负载,内存使用率,带宽使用率等等.
使用wdCP,通过WEB方式就可以轻松创建网站,开站点,发布网站,创建FTP,创建mysql数据库等.
使用wdCP,通过WEB方式,就可以管理服务器上的站点,站点文件,站点配置等等.
使用wdCP,不用再为linux服务器的管理操作犯愁,可以专心开发和运营网站
简单,方便,易操作.让你方便地使用和管理Linux服务器和网站,使用Linux系统做网站服务器,也同样可以很简单
更多的功能介绍请看 http://www.wdlinux.cn/wdcp/

结合最新的lanmp_v3安装包,一键即可完成WEB应用的所有环境和wdCP的安装
可选择安装lamp,lnmp,lnamp相应的应用组合
也可以全部安装,在后台上切换使用不同的组合
更多一键安装包的介绍可看 http://www.wdlinux.cn/bbs/forum-5-1.html

相应软件的版本
nginx-1.8.1
httpd-2.4.18
php-5.6.20
mysql-5.5.48
pureftpd-1.0.42
memcached-1.4.25
wdcp_v3

软件安装目录
/www/wdlinux
数据库文件目录
/www/wdlinux/mysql/data

支持组件
zend,memcache,rewrite,pdo_mysql,mysqli等常用组件

支持系统
wdcp_v3 支持wdOS/CentOS5.x/6.x/7.x
lanmp_v3 支持CentOS 6.X/7.X
lanmp_v2 支持wdOS/CentOS 5.X/6.X

安装说明
全新安装环境全新后台(v3全新完整版)
wget http://dl.wdlinux.cn/files/lanmp_v3.tar.gz
tar zxvf lanmp_v3.tar.gz
sh lanmp.sh

v2的环境v3的后台全新安装
wget http://dl.wdlinux.cn/lanmp_v2.6.tar.gz
tar zxvf lanmp_v2.6.tar.gz
sh install.sh

v2的环境v3的后台全新(快速安装包)
wget http://down.wdlinux.cn/in/lanmp_wdcp_ins.sh
sh lanmp_wdcp_ins.sh

v2的环境v2的后台全新安(即老版本)
wget http://dl.wdlinux.cn/lanmp_v2.5.tar.gz
tar zxvf lanmp_v2.5.tar.gz
sh install.sh

只安装v3的后台系统(v2的升级或v3的独立安装)
wget http://wdcp3.wdlinux.cn/down/install.sh
sh install.sh

关于从v2的升级
对于使用v2的用户
可以单独升级wdcp后台到v3的版本(只安装v3的后台系统就可以,千万不要全新安装,否则很麻烦)
集WEB环境组件的升级包将在后续发布

其它说明
要用v3就没有必要安装v2再升级v3
如果要用v2的环境v3的后台,直接使用v2环境v3后台全新安装即可

安装完检查v3的运行情况
netstat -lnpt 查看是否有8080的端口和wdcp的进程
service wdcp restart 可操作重启

卸载方法
rm -fr /www/wdlinux
reboot


v3的后台演示系统
http://demo.wdlinux.cn
admin
wdlinux.cn
演示服务器由腾讯云提供,现在注册开通,还有260元代金券赠送

后期将会添加的功能
多PHP版本共存的支持,php7的支持
非wdcp一键包安装的应用环境支持
ubuntu,debian的支持
作者: sdgtwt    时间: 2016-4-12 10:49

我发现这个版本里面没有工具包
作者: venuan    时间: 2016-4-12 11:14

后台添加的用户和admin的权限是一样的,多添加一个用户有什么意义呀!能不能添加的用户只能修改属于他自己站点相关的内容,系统相关的设置不能修改,这样才有意义呀!纯属个人意见请见谅!!!
作者: wjdiy    时间: 2016-4-12 11:17

本帖最后由 wjdiy 于 2016-5-21 22:26 编辑

wdcp_v2.5.15 怎么升级
?升级后 phpmyadmin 打不开怎么处理?
001.jpeg
2016-5-21 22:26


图片附件: 001.jpeg (2016-5-21 22:26, 18.99 KB) / 下载次数 1605
http://www.wdlinux.cn/bbs/attachment.php?aid=6166&k=0246b72a9a781d7ab61dd40ae2655810&t=1496071617&sid=GVd1b0


作者: admin    时间: 2016-4-12 11:17

回复 2# sdgtwt


什么工具包
作者: wjdiy    时间: 2016-4-12 11:36

回复 1# admin 我升级后台v3我网站找不开了怎么办?

作者: godor    时间: 2016-4-12 12:14

如何才能支持 多版本PHP共存,不同的站点可以切换   php版本,有几个网站还要用5.2   其他网站要用 5.3以上
作者: wjdiy    时间: 2016-4-12 12:41

Forbidden
You don't have permission to access / on this server.

后台v3打不开!怎么办?刚升级的
作者: 1280081786    时间: 2016-4-12 12:43

这么多版本  装哪一个才是v3完整版本啊
作者: 黑雨    时间: 2016-4-12 15:51

QQ图片20160412154557.png
2016-4-12 15:50

安装到这里提示 PHP安装错误。。

怎么回事?

图片附件: QQ图片20160412154557.png (2016-4-12 15:50, 25.52 KB) / 下载次数 1913
http://www.wdlinux.cn/bbs/attachment.php?aid=5908&k=d5bb460ae067ca9ecce75311359ca833&t=1496071617&sid=GVd1b0


作者: 93656530    时间: 2016-4-12 18:52

安装apche出错。怎么回事
作者: vicbecan    时间: 2016-4-13 00:09

为什么全新的阿里去服务器,全新安装V3版,建立站点,上传安装好网站,发现PHPmyadmin无法打开,提示:Not Found

The requested URL /pma_d4daa363 was not found on this server.
作者: 韩冷君    时间: 2016-4-13 00:32

升级/安装说明
全新安装环境全新后台(v3全新完整版)
wget http://dl.wdlinux.cn/files/lanmp_v3.tar.gz
tar zxvf lanmp_v3.tar.gz
sh lanmp.sh

确定最后不是sh install.sh???如果我需要管理面板全新后台。。。

我刚才这样安装:
wget http://dl.wdlinux.cn:5180/lanmp_laster.tar.gz
tar zxvf lanmp_laster.tar.gz
sh install.sh

安装完8080 不是管理后台
也是提示安装成功的页面
是什么情况???
作者: 韩冷君    时间: 2016-4-13 00:38

我卸载了安装老版本试试
2.5的 ...
之前一台服务器安装的2.5的版本
很顺利
V3好像IP:8080不进入管理面板
不知道是我服务器配置的问题
还是版本的问题
我换旧版本试试先
作者: okhwyy    时间: 2016-4-13 09:13

回复 5# admin


   /www/wdlinux/tools    这种工具包
作者: vfxx    时间: 2016-4-13 09:15

演示网站后台错位了
作者: IGS.CC    时间: 2016-4-13 14:56

太激动人心了!希望越做越好~!
作者: yang900718    时间: 2016-4-13 15:37

非常神速
作者: gutao3800    时间: 2016-4-13 15:54

有mysql 多版本吗?希望能在安装的时候对mysql版本有更多选择。
作者: xtn    时间: 2016-4-13 15:57

修改端口后,不能正常访问
作者: whale    时间: 2016-4-13 16:52

提示: 该帖被管理员或版主屏蔽
作者: xzhuji    时间: 2016-4-13 18:53

本帖最后由 xzhuji 于 2016-4-13 18:55 编辑

回复 1# admin
太好了,支持老大的资源占用少、高效的理念!服务器就是要轻便、安全稳定第一,大家都是用linux的,不能太追求图形界面了,用wdcp就是想快速的部署环境,其他的功能,在不占用服务器资源的情况下,可以适当的有,
总之,网站服务器就是要高效、不占资源、安全稳定,并有较好的数据备份和恢复方案(毕竟做网站,最宝贵的就是数据,除了代码和数据,啥都木有),至于其他的个性化的东西,建议老大让他们有需要的单独安装,默认安装的是最小包就很好,谢谢!支持老大
作者: solar    时间: 2016-4-13 19:07

很期待能解决 安装ECSHOP的PHP版本
作者: 洪福齐天    时间: 2016-4-13 20:03

我的v3后台 v2的环境 php版本5.6.9  其他的没变 现在怎么升级环境啊
作者: wxkxklmyt    时间: 2016-4-14 14:15

老大,请教个问题,我只要一绑定泛解析到子目录,就会造成所有网站出现502错误,怎么解决啊?
作者: longqiang    时间: 2016-4-15 08:18

cenots7.0 全新安装V3 报错

QQ图片20160415081606.png
2016-4-15 08:16


图片附件: QQ图片20160415081606.png (2016-4-15 08:16, 40.22 KB) / 下载次数 541
http://www.wdlinux.cn/bbs/attachment.php?aid=5944&k=dff458a1cdda33157a737cd7be101bc3&t=1496071617&sid=GVd1b0


作者: hobbyplus    时间: 2016-4-15 16:57

安装不太好使,有没有更多的 php版本可选
作者: zhengnan0657    时间: 2016-4-15 21:52

修改端口后,不能正常访问,不能登入
作者: kalok_leung    时间: 2016-4-15 22:46

同样的问题,修改端口后,不能正常访问,不能登入,急死
作者: bayod    时间: 2016-4-16 11:10

回复 29# kalok_leung


    重启下wdcp服务就行。用ssh
作者: bayod    时间: 2016-4-16 11:11

不过感觉安装包安装的时候不太稳定。我装四次里有三次都出问题了
作者: lansh810    时间: 2016-4-16 17:15

我发现V3的 不能修改面板的端口号。我改成20138,直接打不开。

以前,v2的时候是可以的。
作者: lansh810    时间: 2016-4-16 17:22

回复 32# lansh810


    重启后,可以了。。。以前不需要重启。
作者: 526510100    时间: 2016-4-17 00:07

安装成功 8080打不开啊
作者: xccslm    时间: 2016-4-17 12:06

老大。wdcp官方网站http://www.wdlinux.cn/wdcp/install.html  被广告劫持了。
作者: zhengnan0657    时间: 2016-4-17 19:25

回复 30# bayod


   重启也不行。改了后台端口和22端口,现在SSH也登不了
作者: lwbing    时间: 2016-4-18 08:09

支持一下,纵欲更新了
作者: qq17662054    时间: 2016-4-18 15:29

请问全新安装的,PHP版本是5.2怎么破?
作者: mingwd    时间: 2016-4-18 16:55

发现2个问题,一个是/www/web/abc.com这个目录是root权限,不是www的,导致Ftp根目录无法上传文件,第二个就是网站列表里面,所有网址,无法显示搜索结果。
作者: bayod    时间: 2016-4-18 17:31

回复 36# zhengnan0657


   centos 7的吗。注意防火墙有没有开放端口
作者: kamaslau    时间: 2016-4-19 10:43

恭喜发布新版本,感谢提供这么好的免费产品!
作者: besthome    时间: 2016-4-19 15:15

多php版本这不是太有必要,当然初期安装时提供可以,但同时运营时,多版本并存,无疑不现实。
多mysql版本更是没必要。唉,无语啊。
作者: gutao3800    时间: 2016-4-19 19:42

回复 42# besthome


    有一些人是有需求的,你没有不代表别人没有呀。

顺便希望官方能出 安装时,单独选择PHP版本,单独选择MySQL版本,单独选择Apache版本的功能,而不是PHP5.2+MySQL5.1+......和PHP5.6+MySQL5.6......这种,万一需要MySQL5.6+PHP5.2就很尴尬啦。谢谢官方。谢谢开发人员。
作者: zeusgeats    时间: 2016-4-19 22:27

怎么没有sendmail了?wordpress必备的啊
作者: xiaoxiao0    时间: 2016-4-22 13:19

不支持ea加速了,EA加速还是很有效果的,不知道有没有替代产品呢
作者: langzi    时间: 2016-4-23 14:00

回复 1# admin


    wdcp3.0 如何实现网站可以支持中文的url呢
作者: makewood    时间: 2016-4-25 00:16

帖子说明很详细,赞一个
作者: zhoumo310    时间: 2016-4-26 15:58

额,没有用户组管理了。。。。
作者: bor    时间: 2016-4-26 18:23

回复 26# longqiang


   你的解决了吗?
作者: tracy0103    时间: 2016-4-26 19:56

还在用V2,好像还有点问题啊。。。过一段时间再升级
作者: 金满斗    时间: 2016-4-27 14:44

谢谢您的心情劳动。我想升级可惜有几个重要站已经在运行了怕出问题。mysql和php我本身也就升级到5.6 了,再次感谢分享。
作者: jialong520    时间: 2016-4-27 21:14

各位大婶晚上好,请问下,我把面板升级到V3后,怎么用navacat就无法连MYSQL数据库了呢
没升级之前还是好好的,而且升级面板后,用navacat连MYSQL报错的那个数据库IP都和真实的服务器IP都不同了,请问这是为什么呢?
作者: allenwan    时间: 2016-4-28 15:13

本帖最后由 allenwan 于 2016-4-28 15:15 编辑

未标题-1.jpg
2016-4-28 15:15


安装出错, 被迫放弃V3  安装老版了

图片附件: 未标题-1.jpg (2016-4-28 15:15, 653.4 KB) / 下载次数 567
http://www.wdlinux.cn/bbs/attachment.php?aid=6031&k=8a009adc28d9c892ac3a200559bb10d9&t=1496071617&sid=GVd1b0


作者: ucyo123    时间: 2016-4-28 22:35

为什么不把public_html 目录取消了?
作者: venuan    时间: 2016-4-30 14:49

安装试试看 好用不
作者: venuan    时间: 2016-4-30 14:55

已经升级了
作者: wwlinux    时间: 2016-5-3 13:42

顶顶顶顶顶顶顶顶顶顶顶顶顶顶顶顶顶顶
作者: perfectxiaoyi    时间: 2016-5-3 14:39

顶下~~~~~顶下~~~~~顶下~~~~~顶下~~~~~顶下~~~~~顶下~~~~~顶下~~~~~顶下~~~~~顶下~~~~~顶下~~~~~顶下~~~~~顶下~~~~~顶下~~~~~顶下~~~~~
作者: xxrwang    时间: 2016-5-3 15:57

不错的新版本。。可以考虑收费。
作者: xxrwang    时间: 2016-5-3 16:02

版主,其实有个功能为啥一直没改进呢,就是数据库路径安装时能指定吗?
作者: xxrwang    时间: 2016-5-3 16:11

回复 1# admin

版主你好,数据库和网站路径能指定安装吗?难道只能先用磁盘挂载一个www目录再安装?
作者: daolang    时间: 2016-5-5 07:55

论坛头像上传不了
作者: woshisiyu    时间: 2016-5-5 11:34

多PHP版本共存的支持,php7的支持 这个多版本共存什么时候能支持啊
作者: 金满斗    时间: 2016-5-6 08:38

谢谢您的分享,一直在用,很好很强大。再次感谢。
作者: 疆飞    时间: 2016-5-6 11:42

赞一个

V3 后台轻盈!!

希望V3 web 环境升级包快些到来!
作者: 13711219696    时间: 2016-5-6 12:50

装完这个进入设置第二个密码(masql数据的root密码,总是提示原密码错误)怎么解???
作者: zxjzqq    时间: 2016-5-8 01:34

支持个,看看。。
作者: coolwond    时间: 2016-5-9 14:04

楼主啊,不知道能不能加入ubuntu的支持啊?
作者: kuugaloveyou    时间: 2016-5-9 17:59

QQ截图20160509175240.jpg
2016-5-9 17:58
安装了3次都是这个问题,无语了。。。。。

图片附件: QQ截图20160509175240.jpg (2016-5-9 17:58, 46.6 KB) / 下载次数 624
http://www.wdlinux.cn/bbs/attachment.php?aid=6074&k=9aa8dff7ec9a09c831cdb4a790520a06&t=1496071617&sid=GVd1b0


作者: ke7en    时间: 2016-5-9 19:07

服务器重启后  wdcp  无法启动 还要手动启动  怎么回事呢
作者: 本来我不色    时间: 2016-5-10 03:14

支持哈哈!
作者: xwteam    时间: 2016-5-10 14:37

安装试试吧
作者: bychris    时间: 2016-5-11 15:27

请问下V3版本怎么让默认的mysql root能本地远程连接数据库? 试过开启3306端口,也试过关闭防火墙都不成功。
作者: emeee    时间: 2016-5-15 21:17

非常不错啊
作者: wjdiy    时间: 2016-5-15 22:12

升级问题还没解决!
作者: hyqlhy    时间: 2016-5-16 11:10

那个后台建立网站后,好似FTP没有权限啊
作者: keepgong    时间: 2016-5-17 09:56

回复 1# admin


    相应软件的版本
nginx-1.8.1
httpd-2.4.18
php-5.6.20
mysql-5.5.48
pureftpd-1.0.42
memcached-1.4.25
wdcp_v3

为啥我登陆phpadmin 里面mysqll版本显示却是5.1的
作者: seocgr    时间: 2016-5-17 17:36

安装报错,32位跟64位都这样。
作者: 令飞    时间: 2016-5-20 01:40

wdCP v3.0.2 下安装Discuz! X3.2 GBK出现乱码,只能安装UTF8 版 怎么解决呢?
作者: beyond263    时间: 2016-5-20 08:45

回复 3# venuan


   这个的确 权限一模一样 没差别的管理添加了意义也不大了
作者: 幸福的路痴    时间: 2016-5-20 13:55

特意登陆论坛,感谢作者的付出!
作者: 2727    时间: 2016-5-21 15:04

回复 1# admin


    安装时提示如图:
QQ图片20160521145220.png
2016-5-21 15:02

想卸载重新安装又提示:
QQ图片20160521145750.jpg
2016-5-21 15:03

装了两次都是一样;
操作系统是: CentOS 7.0 64位

图片附件: QQ图片20160521145220.png (2016-5-21 15:02, 73.8 KB) / 下载次数 546
http://www.wdlinux.cn/bbs/attachment.php?aid=6162&k=2fd039251b1b3ac350965ec25dc94ca5&t=1496071617&sid=GVd1b0



图片附件: QQ图片20160521145750.jpg (2016-5-21 15:03, 41.6 KB) / 下载次数 556
http://www.wdlinux.cn/bbs/attachment.php?aid=6163&k=cf196bf00d8c5a3319106b0f0fd92b51&t=1496071617&sid=GVd1b0


作者: wmhack    时间: 2016-5-23 00:52

更新到了  V3   网站经常会出现   404 Not Found     还有   502

页面是存在的。可要等好一会,才可以继续访问刚刚进不了的页面。/
作者: DT27    时间: 2016-5-24 15:07

终于有API了,有时间好好看看
作者: 6403457    时间: 2016-5-24 16:45

FTP会产生533错误 导致无法编辑/覆盖文件  必须手动将网站目录的所有组和所有者设置为www并继承才能解决,但是这样做不知道会不会有安全隐患,老大请回答一下
作者: phpiii    时间: 2016-5-25 10:41

密码限制了不好,密码都是越复杂越好,V2的时候都会加符号之类的,V3不支持了。希望这个密码不要限制的好
作者: 潮音古韵    时间: 2016-5-26 15:30

数据库和wdcp程序所在服务器分离后,新建ftp无法连接,其他功能正常,我是之前v2版本需要分离开,因为数据库和程序在同一个服务器,当访问者很多时,那时数据库出现几次关闭状态,服务器倒没事。老大未来可以从分布式服务器上入手
作者: yl19850329    时间: 2016-5-26 16:31

1.计划任务 里老版本里的几个默认计划任务没有了
2./www/web/default/pma_256f2116 这个文件夹不能删除吧?好多php文件
作者: pnrs    时间: 2016-5-26 23:19

本帖最后由 pnrs 于 2016-5-26 23:21 编辑

为什么我安装后,管理界面是竖着显示?V3.0.2版本的
QQ截图20160526223337.png
2016-5-26 23:17


图片附件: QQ截图20160526223337.png (2016-5-26 23:17, 12.84 KB) / 下载次数 556
http://www.wdlinux.cn/bbs/attachment.php?aid=6198&k=a3dea4eb20ca5ac3a55e2c564de79f78&t=1496071617&sid=GVd1b0


作者: 桂林仔    时间: 2016-5-27 00:03

QQ截图20160526235655.png
2016-5-27 00:02
我把原来的V2.5卸载后安装V3.1,出现这个情况

图片附件: QQ截图20160526235655.png (2016-5-27 00:02, 31.51 KB) / 下载次数 534
http://www.wdlinux.cn/bbs/attachment.php?aid=6199&k=a8ac28716680300cd615b6147c9baa01&t=1496071617&sid=GVd1b0


作者: admin    时间: 2016-5-27 13:17

先把云锁卸载再安装试试
作者: fengsil    时间: 2016-5-29 23:46

本帖最后由 fengsil 于 2016-5-29 23:49 编辑

大神,请关注一个问题,apache的安装错误。
----Install Error: apache make err---------------
我搜索发现,这个错误的人数不少。
主要是centos 5.6   5.8  等版本的人出现。
个人猜测可能日、韩、东南亚的服务器或者VPS上出现问题较多。

就我个人而言是centos 5.6 位于日本的一个VPS出现的问题。

在更早的版本里边,有一个解决方案:
参见
http://www.wdlinux.cn/bbs/thread-2152-1-1.html

提出:直接修改lanmp.sh里面加上“--with-included-apr” 并最终解决。

但V3版本里边,看了好一阵,没找到添加在哪里合适,我是小白。。。

该问题应该是一个符合条件即必然发生的错误。

请各位大神帮忙解决此问题。

(若有必要我可以提供VPS帐号密码实测解决。)
作者: 炉火纯黑    时间: 2016-6-2 19:18

我想安装V2环境,V3后台,中间12345选哪个?另外,我安装的时候都选择了5,升级几次了不成功怎么回事!
作者: 金满斗    时间: 2016-6-4 08:39

真的感谢这么好的软件
作者: sjj8588    时间: 2016-6-8 23:16

如何才能支持 多版本PHP共存,不同的站点可以切换   php版本,有几个网站还要用5.2   其他网站要用 5 ...
godor 发表于 2016-4-12 12:14
同意的顶
作者: woshisiyu    时间: 2016-6-9 18:02

回复 95# sjj8588


    据说后期会增加多php版本共存 但就是不知道得等多久呀
作者: 飞鱼不寂寞    时间: 2016-6-16 16:08

wdCP V3云主机服务器管理系
作者: Chilsion    时间: 2016-6-18 00:21

建议把之前版本的后台登陆验证码加上。
作者: hanjunsu    时间: 2016-6-18 23:18

支持!!!!!!!!!!!!!!
作者: hmcyh    时间: 2016-6-26 17:50

回复 23# solar


   ecshop没有问题啊,一直用WDCP的




欢迎光临 WDlinux官方论坛 (http://www.wdlinux.cn/bbs/) Powered by Discuz! 7.2