无标题文档
WDCDN联

盟内部测试火热进行中
wdCP系统 (介绍,功能特性,运行环境,安装说明,演示,常见问题,使用教程) wdCDN系统 (介绍,功能特性,运行环境,安装说明,演示,常见问题,使用手册)
wdOS系统 (介绍,功能特性,运行环境,安装说明,演示,常见问题,使用教程) wdDNS系统 (介绍,功能特性,运行环境,安装说明,演示,常见问题,使用手册)
注册 发贴 提问 回复-必看必看 wddns免费智能 DNS 开通 本地或虚拟机使 用wdcp 一键包在mysql编 译时"卡住"
【300G高防】双线 无视攻击 wdcp官方技术支持/服务 阿里云8折优惠券 无敌云 腾讯云优惠中,现注册更有260代金额券赠送
返回列表 发帖
提问三步曲: 提问先看教程/FAQ索引(wdcp,wdcp_v3,一键包)及搜索,会让你更快解决问题
1 提供详细,如系统版本,wdcp版本,软件版本等及错误的详细信息,贴上论坛或截图发论坛
2 做过哪些操作或改动设置等

温馨提示:信息不详,很可能会没人理你!论坛有教程说明的,也可能没人理!因为,你懂的
回复 12# ngibo1278


   重起下,再升级PHP试下
看清提问三步曲及多看教程/FAQ索引(wdcp,v3,一键包,wdOS),益处多多.wdcp工具集 阿里云主机8折优惠码

TOP

本帖最后由 夏筱羽 于 2012-10-9 00:37 编辑

升級5.3 php.ini被清空了,先拿5.2.17的php.ini來頂著先
memcache 後台有啟用 phpinfo 確實顯示不支持,還在查原因當中。

TOP

回复 7# admin


   探针里

TOP

回复 17# 夏筱羽


   5.2的php.ini可能不同,在源码目录里找下php.ini-product就可以了
memcache看下是不是PHP扩展支持没安装好
看清提问三步曲及多看教程/FAQ索引(wdcp,v3,一键包,wdOS),益处多多.wdcp工具集 阿里云主机8折优惠码

TOP

回复 18# hoteri


   奇怪,我这边测试的都可以呀
看清提问三步曲及多看教程/FAQ索引(wdcp,v3,一键包,wdOS),益处多多.wdcp工具集 阿里云主机8折优惠码

TOP

回复 20# admin


   等下我用全新安装一次试验

TOP

谢谢老大,重启了服务器,按照教程升级了MYSQL、PHP,显示升级成功,在phpadmin中查看,里面显示mysql版本已经正确;只是探针、端口测试,发现php版本还是原来的老样子,显示的是php 5.2.17P1,同时在WDCP面板后台修改php设置,发现php.ini文件不存在;通过端口测试IP地址,返回的信息同样是php 5.2.17P1
网页返回HEAD信息如下
Server: nginx/1.0.15
Date: Tue, 09 Oct 2012 05:22:39 GMT
Content-Type: text/html
Connection: keep-alive
Vary: Accept-Encoding
X-Powered-By: PHP/5.2.17p1
Content-Length: 2597

重启nginx的时候发现
Starting nginx: nginx: [emerg] bind() to 0.0.0.0:80 failed (98: Address already in use)

我用的是centos 6.2,使用lanmp,这是升级成功了?还是要修改下什么设置?另外,直接把php压缩包的php.ini文件复制WDCP面板设置php.ini文件的位置行不行?

TOP

怎么我的php版本升级后重启了两次,还是5.2.17p1呢。这是怎么回事,
还有就是Zend Guard Loader安装时,下载不了.rmp的一个什么编译包。
五龙影视

TOP

开始升级2.5到后 接着php版本 升级后php.ini也不在了,这是搞什么。php版本还是显示php5.2.17p1
网站还能运行。系统切换,检测不到nginx或php-cgi,这是怎么了,只能用apache了。
五龙影视

TOP

回复 22# ngibo1278


   如果php.ini 文件为空的话,从PHP的源码目录里拷一份即可,
如cd php-5.3.17
cp php.ini-production /www/wdlinux/apache_php/etc/php.ini
cp php.ini-production /www/wdlinux/nginx_php/etc/php.ini
看清提问三步曲及多看教程/FAQ索引(wdcp,v3,一键包,wdOS),益处多多.wdcp工具集 阿里云主机8折优惠码

TOP

回复 24# chen7413


   还是显示php5.2.17的话,是没升级成功,可以把相关提示信息贴上来
看清提问三步曲及多看教程/FAQ索引(wdcp,v3,一键包,wdOS),益处多多.wdcp工具集 阿里云主机8折优惠码

TOP

123.jpg
2012-10-9 19:29


貌似这个升级的程序真的有问题,上图显示php is update,实际上不管是探针,还是直接去/www/wdlinux/目录查看,都没有找到对应的文件,依然是php 5.2.17P1

apache环境下的:libmysqlclient.so.18: cannot open shared object file: No such file or directory
make: *** [ext/phar/phar.php] Error 127

另外,nginx环境下的php貌似压根没安装过,似乎是读写失败什么的

我的运行环境:centos 6.2 64位  通过rpm快速安装的lanmp组合,先升级的mysql,随后升级的php

升级mysql的方法
wget http://down.wdlinux.cn/in/mysql_up55.sh
sh mysql_up55.sh


升级php的方法
wget http://down.wdlinux.cn/in/php_up53.sh
sh php_up53.sh

TOP

是因为libmysqlclient.so这个没有编译成功,但脚本又没判断,所以这样
已经做过调整

mysql是否正常?有没重起过

如果没有重起过,重起下,再次安装试试
重新下载php_up53.sh,下载前先删php_up53.sh
看清提问三步曲及多看教程/FAQ索引(wdcp,v3,一键包,wdOS),益处多多.wdcp工具集 阿里云主机8折优惠码

TOP

折腾了两个夜晚,终于成功了,谢谢老大的耐心指导!
正确的升级流程是:先安装WDCP面板,随后安装cmake,一定要安装这个文件,随后升级php,随后升级相关的php缓存插件,随后升级mysql,这样才完全升级成功。之前出错可能是cmake文件的版本问题,开始用的高版本,后来换到低版本,再先升级php,这样才行;先升级mysql,后面安装php要调整很多地方。

TOP

wget http://down.wdlinux.cn/in/ZendGL_ins.sh
sh ZendGL_ins.sh

zend 安装不成功

TOP

返回列表