无标题文档
WDCDN联

盟内部测试火热进行中
wdCP系统 (介绍,功能特性,运行环境,安装说明,演示,常见问题,使用教程) wdCDN系统 (介绍,功能特性,运行环境,安装说明,演示,常见问题,使用手册)
wdOS系统 (介绍,功能特性,运行环境,安装说明,演示,常见问题,使用教程) wdDNS系统 (介绍,功能特性,运行环境,安装说明,演示,常见问题,使用手册)
注册 发贴 提问 回复-必看必看 wddns免费智能 DNS 开通 本地或虚拟机使 用wdcp 一键包在mysql编 译时"卡住"
【300G高防】双线 无视攻击 wdcp官方技术支持/服务 阿里云8折优惠券 无敌云 腾讯云优惠中,现注册更有260代金额券赠送
返回列表 发帖
提问三步曲: 提问先看教程/FAQ索引(wdcp,wdcp_v3,一键包)及搜索,会让你更快解决问题
1 提供详细,如系统版本,wdcp版本,软件版本等及错误的详细信息,贴上论坛或截图发论坛
2 做过哪些操作或改动设置等

温馨提示:信息不详,很可能会没人理你!论坛有教程说明的,也可能没人理!因为,你懂的

[求助] Install Error: mysql configure err 安不了

[root@AY140528162754239263Z ~]# sh install.sh
Setting up Install Process
No package screen available.
Nothing to do
Cannot find 'screen' command,install without screen(default yes)?
(Yes/No): yes
grep: /etc/redhat-release: No such file or directory
Select Install
    1 apache + php + mysql + zend + eAccelerator + pureftpd + phpmyadmin
    2 nginx + php + mysql + zend + eAccelerator + pureftpd + phpmyadmin
    3 nginx + apache + php + mysql + zend + eAccelerator + pureftpd + phpmyadmin
    4 install all service
    5 don't install is now

Please Input 1,2,3,4,5: 4
Select php version:
    1 php-5.2.17 (default)
    2 php-5.3.27

Please Input 1,2: 2
error: skipping http://pkgs.repoforge.org/rpmforge-release/rpmforge-release-0.5.3-1.el5.rf.x86_64.rpm - transfer failed - Unknown or unexpected error
Retrieving http://pkgs.repoforge.org/rpmforge-release/rpmforge-release-0.5.3-1.el5.rf.x86_64.rpm
Setting up Install Process
No package gcc-c++ available.
No package autoconf available.
No package libtool-ltdl-devel available.
No package gd-devel available.
No package freetype-devel available.
No package libxml2-devel available.
No package libjpeg-devel available.
No package libpng-devel available.
No package openssl-devel available.
No package curl-devel available.
No package patch available.
No package libmcrypt-devel available.
No package libmhash-devel available.
No package ncurses-devel available.
No package libcap-devel available.
No package sendmail available.
No package unzip available.
Nothing to do
29 May 11:04:56 ntpdate[1541]: the NTP socket is in use, exiting
setenforce: SELinux is disabled
sed: can't read /etc/selinux/config: No such file or directory

installing mysql,this may take a few minutes,hold on plz...
configure in progress ...


----Install Error: mysql configure err -----------


grep: /etc/redhat-release: No such file or directory
Preparing...                ##################################################
rpmforge-release            ##################################################
Setting up Install Process
No package gcc-c++ available.
No package autoconf available.
No package libtool-ltdl-devel available.
No package gd-devel available.
No package freetype-devel available.
No package libxml2-devel available.
No package libjpeg-devel available.
No package libpng-devel available.
No package openssl-devel available.
No package curl-devel available.
No package patch available.
No package ncurses-devel available.
No package libcap-devel available.
No package unzip available.
Resolving Dependencies
--> Running transaction check
---> Package libmcrypt-devel.x86_64 0:2.5.7-1.2.el5.rf set to be updated
--> Processing Dependency: libmcrypt = 2.5.7-1.2.el5.rf for package: libmcrypt-devel
--> Processing Dependency: libmcrypt.so.4()(64bit) for package: libmcrypt-devel
---> Package mhash-devel.x86_64 0:0.9.9-1.el5.rf set to be updated
--> Processing Dependency: mhash = 0.9.9-1.el5.rf for package: mhash-devel
--> Processing Dependency: libmhash.so.2()(64bit) for package: mhash-devel
--> Running transaction check
---> Package libmcrypt.x86_64 0:2.5.7-1.2.el5.rf set to be updated
---> Package mhash.x86_64 0:0.9.9-1.el5.rf set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package               Arch         Version                Repository      Size
================================================================================
Installing:
libmcrypt-devel       x86_64       2.5.7-1.2.el5.rf       rpmforge       112 k
mhash-devel           x86_64       0.9.9-1.el5.rf         rpmforge        19 k
Installing for dependencies:
libmcrypt             x86_64       2.5.7-1.2.el5.rf       rpmforge       182 k
mhash                 x86_64       0.9.9-1.el5.rf         rpmforge       161 k

Transaction Summary
================================================================================
Install       4 Package(s)
Upgrade       0 Package(s)

Total download size: 475 k
Downloading Packages:
--------------------------------------------------------------------------------
Total                                           116 kB/s | 475 kB     00:04
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : mhash                                                    1/4
  Installing     : libmcrypt                                                2/4
  Installing     : mhash-devel                                              3/4
  Installing     : libmcrypt-devel                                          4/4

Installed:
  libmcrypt-devel.x86_64 0:2.5.7-1.2.el5.rf mhash-devel.x86_64 0:0.9.9-1.el5.rf

Dependency Installed:
  libmcrypt.x86_64 0:2.5.7-1.2.el5.rf       mhash.x86_64 0:0.9.9-1.el5.rf

Complete!
29 May 11:06:00 ntpdate[7794]: the NTP socket is in use, exiting
setenforce: SELinux is disabled
sed: can't read /etc/selinux/config: No such file or directory

installing mysql,this may take a few minutes,hold on plz...
configure in progress ...


----Install Error: mysql configure err -----------

我老是安装在这儿,是Aliyun Linux 5.7 64位系统,不要说去看教程,我安照教程说的按了无数遍还是不行,不知道这个安装包怎么回事。

install error: mysql configure err解决方法

出现这个错误是因为脚本里面的环境由于未知的原因没有装上运行以下两行重新安装即可
  1. yum install -y gcc cmake ncurses-devel
  2. rm -rf ./src/mysql*
复制代码

TOP

回复 2# fox1383164k


    太感谢你了,你的回答解决了我的问题。

我装的CENTOS 7.3,VPS 购买好,第一次安装WDCP 3.2很顺利,提示安装成功,只是IP:8080 死活打不开,

解决不了,我就面板上重装了系统,结果不是这错误就是那错误,怎么就是安装不了,
然后我又装6.X的系统,还是出错,
然后又装7.3

没办法了,仔细看错误就是Install Error: mysql configure err
百度几个答案都解决不了,
换你的就不提示这个错误了,等下安装完看能成功不。

TOP

返回列表