无标题文档
WDCDN联

盟内部测试火热进行中
wdCP系统 (介绍,功能特性,运行环境,安装说明,演示,常见问题,使用教程) wdCDN系统 (介绍,功能特性,运行环境,安装说明,演示,常见问题,使用手册)
wdOS系统 (介绍,功能特性,运行环境,安装说明,演示,常见问题,使用教程) wdDNS系统 (介绍,功能特性,运行环境,安装说明,演示,常见问题,使用手册)
注册 发贴 提问 回复-必看必看 wddns免费智能 DNS 开通 本地或虚拟机使 用wdcp 一键包在mysql编 译时"卡住"
【300G高防】双线 无视攻击 wdcp官方技术支持/服务 阿里云8折优惠券 无敌云 腾讯云优惠中,现注册更有260代金额券赠送
返回列表 发帖
提问三步曲: 提问先看教程/FAQ索引(wdcp,wdcp_v3,一键包)及搜索,会让你更快解决问题
1 提供详细,如系统版本,wdcp版本,软件版本等及错误的详细信息,贴上论坛或截图发论坛
2 做过哪些操作或改动设置等

温馨提示:信息不详,很可能会没人理你!论坛有教程说明的,也可能没人理!因为,你懂的

[求助] 我安装2.5的版本的时候出现Install Error: mysql configure err

本帖最后由 shin0406 于 2016-6-28 16:48 编辑

以下是出错情况
我用的阿里云 ECS服务器
我的系统是 cent os 6.5 64位


[root@iZ25ps2cpynZ ~]# sh install.sh
Loaded plugins: security
Setting up Install Process
No package screen available.
Error: Nothing to do
Cannot find 'screen' command,install without screen(default yes)?
(Yes/No): Yes
Select Install
    1 apache + php + mysql + zend + eAccelerator + pureftpd + phpmyadmin
    2 nginx + php + mysql + zend + eAccelerator + pureftpd + phpmyadmin
    3 nginx + apache + php + mysql + zend + eAccelerator + pureftpd + phpmyadmin
    4 install all service
    5 don't install is now

Please Input 1,2,3,4,5: 4
Select php version:
    1 php-5.2.17 (default)
    2 php-5.3.29

Please Input 1,2: 2
Retrieving http://pkgs.repoforge.org/rpmforge-release/rpmforge-release-0.5.3-1.e                                                              l6.rf.x86_64.rpm
Preparing...                ##################################################
rpmforge-release            ##################################################
Loaded plugins: security
^CWarning: RPMDB altered outside of yum.
28 Jun 15:37:17 ntpdate[1200]: the NTP socket is in use, exiting
setenforce: SELinux is disabled
Preparing...                ##################################################
        package rpmforge-release-0.5.3-1.el6.rf.x86_64 (which is newer than rpmforge-release-0.5.2-                                           2.el5.rf.x86_64) is already installed
        file /etc/apt/sources.list.d/rpmforge-extras.list from install of rpmforge-release-0.5.2-2.                                           el5.rf.x86_64 conflicts with file from package rpmforge-release-0.5.3-1.el6.rf.x86_64
        file /etc/apt/sources.list.d/rpmforge-testing.list from install of rpmforge-release-0.5.2-2                                           .el5.rf.x86_64 conflicts with file from package rpmforge-release-0.5.3-1.el6.rf.x86_64
        file /etc/apt/sources.list.d/rpmforge.list from install of rpmforge-release-0.5.2-2.el5.rf.                                           x86_64 conflicts with file from package rpmforge-release-0.5.3-1.el6.rf.x86_64
        file /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmforge-dag from install of rpmforge-release-0.5.2-2.el5                                           .rf.x86_64 conflicts with file from package rpmforge-release-0.5.3-1.el6.rf.x86_64
        file /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmforge-fabian from install of rpmforge-release-0.5.2-2.                                           el5.rf.x86_64 conflicts with file from package rpmforge-release-0.5.3-1.el6.rf.x86_64
        file /etc/smart/channels/rpmforge.channel from install of rpmforge-release-0.5.2-2.el5.rf.x                                           86_64 conflicts with file from package rpmforge-release-0.5.3-1.el6.rf.x86_64
        file /etc/sysconfig/rhn/sources.rpmforge.txt from install of rpmforge-release-0.5.2-2.el5.r                                           f.x86_64 conflicts with file from package rpmforge-release-0.5.3-1.el6.rf.x86_64
        file /etc/yum.repos.d/mirrors-rpmforge from install of rpmforge-release-0.5.2-2.el5.rf.x86_                                           64 conflicts with file from package rpmforge-release-0.5.3-1.el6.rf.x86_64
        file /etc/yum.repos.d/mirrors-rpmforge-extras from install of rpmforge-release-0.5.2-2.el5.                                           rf.x86_64 conflicts with file from package rpmforge-release-0.5.3-1.el6.rf.x86_64
        file /etc/yum.repos.d/mirrors-rpmforge-testing from install of rpmforge-release-0.5.2-2.el5                                           .rf.x86_64 conflicts with file from package rpmforge-release-0.5.3-1.el6.rf.x86_64
        file /etc/yum.repos.d/rpmforge.repo from install of rpmforge-release-0.5.2-2.el5.rf.x86_64                                            conflicts with file from package rpmforge-release-0.5.3-1.el6.rf.x86_64
Loaded plugins: security
Setting up Install Process
No package libtool-ltdl-devel available.
No package gd-devel available.
No package freetype-devel available.
No package libxml2-devel available.
No package libjpeg-devel available.
No package libpng-devel available.
No package openssl-devel available.
No package curl-devel available.
Package libmcrypt-devel-2.5.7-1.2.el6.rf.x86_64 already installed and latest version
Package mhash-devel-0.9.9-1.el6.rf.x86_64 already installed and latest version
No package ncurses-devel available.
No package libcap-devel available.
No package sysklogd available.
Nothing to do
28 Jun 15:37:20 ntpdate[1252]: the NTP socket is in use, exiting
setenforce: SELinux is disabled

installing mysql,this may take a few minutes,hold on plz...
configure in progress ...


----Install Error: mysql configure err -----------

yum更新有问题
看清提问三步曲及多看教程/FAQ索引(wdcp,v3,一键包,wdOS),益处多多.wdcp工具集 阿里云主机8折优惠码

TOP

回复 2# admin


    那么怎么解决呢?

TOP

CentOS

1、备份

mv /etc/yum.repos.d/CentOS-Base.repo /etc/yum.repos.d/CentOS-Base.repo.backup

2、下载新的CentOS-Base.repo 到/etc/yum.repos.d/

CentOS 5

wget -O /etc/yum.repos.d/CentOS-Base.repo http://mirrors.aliyun.com/repo/Centos-5.repo

或者
curl -o /etc/yum.repos.d/CentOS-Base.repo http://mirrors.aliyun.com/repo/Centos-5.repo

CentOS 6

wget -O /etc/yum.repos.d/CentOS-Base.repo http://mirrors.aliyun.com/repo/Centos-6.repo

或者
curl -o /etc/yum.repos.d/CentOS-Base.repo http://mirrors.aliyun.com/repo/Centos-6.repo

CentOS 7

wget -O /etc/yum.repos.d/CentOS-Base.repo http://mirrors.aliyun.com/repo/Centos-7.repo

或者
curl -o /etc/yum.repos.d/CentOS-Base.repo http://mirrors.aliyun.com/repo/Centos-7.repo

3、之后运行yum makecache生成缓存

TOP

返回列表